Hypertext Transfer Protocol
Application-layer protocol for transferring web resources
Also known as HTTP · http:
- Instance of
- Founded
- 1989
- Website
Overview
All data
87 statements · 17% with external sources · numbers in brackets are citations
- Port
- 80 protocol: Transmission Control Protocol
- 80 protocol: User Datagram Protocol
- 80 protocol: Stream Control Transmission Protocol
- Discovered by
- Tim Berners-Lee
1
Sources- 1.“HyperText Transfer Protocol”w3.org/History/19921103-hypertext/hypertext/WWW/Protocols/HTTP.html
- Tim Berners-Lee
- Released
- 1990
2
Sources- 1.Stated in RFC 9110: HTTP SemanticsRetrieved 2022-06-07
- 2.Stated in RFC 9110: HTTP SemanticsRetrieved 2022-06-07
- 1990
- Latest version
- 3 statement is subject of: HTTP/3
1
- 0.9
1
Sources- 1.“The HTTP Protocol As Implemented In W3”w3.org/Protocols/HTTP/AsImplemented.htmlRetrieved 2017-07-22
- 1.1 statement is subject of: HTTP/1.1
- 1.0 statement is subject of: HTTP/1.0
- 2 statement is subject of: HTTP/2
- 3 statement is subject of: HTTP/3
- Media type
- message/http
2
Sources- 1.iana.org/assignments/media-types/message/httpRetrieved 2018-06-23
- 2.Stated in RFC 7230: Hypertext Transfer Protocol (HTTP/1.1): Message Syntax and Routing
- application/http
2
Sources- 1.iana.org/assignments/media-types/application/httpRetrieved 2018-06-23
- 2.Stated in RFC 7230: Hypertext Transfer Protocol (HTTP/1.1): Message Syntax and Routing
- message/http
- OSI Model layer location
- application layer
1
Sources- 1.Stated in RFC 1945: Hypertext Transfer Protocol -- HTTP/1.0Retrieved 2022-05-28
- application layer
- Short name
- HTTP
- HTTP
- HTTP
On other databases
39 identifiers linking Hypertext Transfer Protocol across the web's reference databases
- Baidu Tieba namehttp
- Bibliothèque nationale de France ID12556450f
- Brockhaus Enzyklopädie online IDhttp-informatik
- De Agostini IDHTTP
- Encyclopædia Britannica Online IDtechnology/HTTP
- Encyclopedia of China (Third Edition) ID (2026)315AeT
- Encyclopedia of China (Third Edition) old ID (2021)106780
- Fandom article IDhtmlcss:HTTP
- File Format Wiki page IDHTTP
- FOLDOC IDHTTP
- Freebase ID/m/03hgt
- GitHub topichttp
- GitLab.com topic IDhttp
- GND ID4479982-2
- Great Norwegian Encyclopedia IDHTTP
- IANA service namehttp
- ICANNWiki page IDHTTP
- J9U entity ID987007549387405171
- JSTOR topic ID (archived)http
- KBpedia IDHypertextTransferProtocol
- Lex IDHTTP
- Library of Congress Authorities IDsh97000529
- Microsoft Academic ID (discontinued)149672775
- Mozilla Developer Network articleWeb/HTTP
- Namuwiki IDHTTP
- NE.se IDhttp
- NicoNicoPedia word article IDhttp
- Open Library subject IDhttp_(computer_network_protocol)
- OpenAlex IDC149672775
- Quora topic IDHTTP
- ScienceDirect topic IDcomputer-science/hyper-text-transfer-protocol
- Semantic Scholar topic ID28225
- TDKIV term ID000000615
- TDKIV Wikibase IDQ642
- Treccani IDhttp
- Treccani's Enciclopedia della Matematica IDhttp
- Treccani's Lessico del XXI Secolo IDhttp
- Uniform Resource Identifier Schemehttp
- Yale LUX IDconcept/3d05d629-a88c-4190-916a-e9a18bf4b9d5