# URI schemes (IANA registry)

| Scheme | Description | Status | Well-known URIs | CRI scheme number | Defining RFC | References |
| --- | --- | --- | --- | ---: | ---: | --- |
| aaa | Diameter Protocol | Permanent |  | 13862 | 6733 | RFC 6733 |
| aaas | Diameter Protocol with Secure Transport | Permanent |  | 14526 | 6733 | RFC 6733 |
| about | about | Permanent |  | 3786 | 6694 | RFC 6694 |
| acap | application configuration access protocol | Permanent |  | 12705 | 2244 | RFC 2244 |
| acct | acct | Permanent |  | 10229 | 7565 | RFC 7565 |
| acd | acd | Provisional |  | 6840 |  |  |
| ace | ace | Provisional |  | 26 |  |  |
| aceap | aceap | Provisional |  | 1034 |  |  |
| acedp | acedp | Provisional |  | 1035 |  |  |
| aceep | aceep | Provisional |  | 1036 |  |  |
| acelp | acelp | Provisional |  | 1037 |  |  |
| aceup | aceup | Provisional |  | 1038 |  |  |
| acr | acr | Provisional |  | 10196 |  | OMA-OMNA |
| adiumxtra | adiumxtra | Provisional |  | 6634 |  |  |
| adt | adt | Provisional |  | 5150 |  | SAP SE |
| aet | aet | Provisional |  | 1020 |  |  |
| afp | afp | Provisional |  | 13404 |  |  |
| afs | Andrew File System global file names | Provisional |  | 10687 | 1738 | RFC 1738 |
| agtp | agtp | Provisional |  | 1006 |  |  |
| aim | aim | Provisional |  | 10327 |  |  |
| alter | alter | Provisional |  | 1031 |  | draft-morrison-alter-uri-scheme-03 |
| amss | amss | Provisional |  | 10831 |  |  |
| android | android | Provisional |  | 15061 |  | https://developer.android.com/guide/topics/manifest/manifest-intro |
| appdata | appdata | Provisional |  | 7364 |  |  |
| apt | apt | Provisional |  | 7856 |  |  |
| ar | ar | Provisional |  | 5099 |  |  |
| ari | ari | Provisional |  | 3818 |  | draft-ietf-dtn-ari-04 |
| ark | ark | Provisional |  | 3018 |  | https://n2t.net/ark:/21206/10015 |
| ars | ars | Provisional |  | 1025 |  | draft-juwan-ars-uri-00 |
| arv | arv | Provisional |  | 1032 |  |  |
| at | at (see [reviewer notes]) | Provisional |  | 6007 |  |  |
| attachment | attachment | Provisional |  | 8577 |  |  |
| aw | aw | Provisional |  | 16051 |  |  |
| barion | barion | Provisional |  | 10225 |  |  |
| bb | bb | Historical |  | 5188 |  | IESG |
| beshare | beshare | Provisional |  | 4674 |  |  |
| bitcoin | bitcoin | Provisional |  | 9186 |  |  |
| bitcoincash | bitcoincash | Provisional |  | 7226 |  |  |
| bl | bluetooth (shortened) | Provisional |  | 10024 |  |  |
| blob | blob | Provisional |  | 11060 |  |  |
| bluetooth | bluetooth | Provisional |  | 12052 |  |  |
| bolo | bolo | Provisional |  | 8765 |  |  |
| brid | brid | Provisional |  | 8251 |  |  |
| browserext | browserext | Provisional |  | 4327 |  |  |
| cabal | cabal | Provisional |  | 11393 |  |  |
| caip | caip | Provisional |  | 1001 |  |  |
| calculator | calculator | Provisional |  | 3783 |  |  |
| callto | callto | Provisional |  | 8713 |  |  |
| canactid | canactid | Provisional |  | 1033 |  | draft-schrock-canonical-action-identifier-05 |
| cap | Calendar Access Protocol | Permanent |  | 9204 | 4324 | RFC 4324 |
| cast | cast | Provisional |  | 1220 |  | https://developers.google.com/cast/docs/registration |
| casts | casts | Provisional |  | 12718 |  | https://developers.google.com/cast/docs/registration |
| chrome | chrome | Provisional |  | 5728 |  |  |
| chrome-extension | chrome-extension | Provisional |  | 14667 |  |  |
| cid | content identifier | Permanent |  | 15202 | 2392 | RFC 2392 |
| cm | cm | Provisional |  | 1021 |  |  |
| coap | coap | Permanent | [RFC 7252] | 0 | 7252 | RFC 7252 |
| coap+tcp | coap+tcp (see [reviewer notes]) | Permanent | [RFC 8323] | 6 | 8323 | RFC 8323 |
| coap+ws | coap+ws (see [reviewer notes]) | Permanent | [RFC 8323] | 24 | 8323 | RFC 8323 |
| coaps | coaps | Permanent | [RFC 7252] | 1 | 7252 | RFC 7252 |
| coaps+tcp | coaps+tcp (see [reviewer notes]) | Permanent | [RFC 8323] | 7 | 8323 | RFC 8323 |
| coaps+ws | coaps+ws (see [reviewer notes]) | Permanent | [RFC 8323] | 25 | 8323 | RFC 8323 |
| com-eventbrite-attendee | com-eventbrite-attendee | Provisional |  | 9278 |  |  |
| content | content | Provisional |  | 8387 |  |  |
| content-type | content-type | Provisional |  | 6030 |  |  |
| crid | TV-Anytime Content Reference Identifier | Permanent |  | 5990 | 4078 | RFC 4078 |
| cstr | cstr | Provisional |  | 6730 |  |  |
| cttps | cttps | Provisional |  | 1007 |  |  |
| cvs | cvs | Provisional |  | 12242 |  |  |
| dab | dab | Provisional |  | 6774 |  |  |
| dat | dat | Provisional |  | 10583 |  |  |
| data | data | Permanent |  | 1946 | 2397 | RFC 2397 |
| dav | dav | Permanent |  | 4373 | 4918 | RFC 4918 |
| dhttp | dhttp (see [reviewer notes]) | Provisional |  | 4549 |  |  |
| diaspora | diaspora | Provisional |  | 4598 |  |  |
| dict | dictionary service protocol | Permanent |  | 3886 | 2229 | RFC 2229 |
| did | did | Provisional |  | 5 |  |  |
| dilithium3 | dilithium3 | Provisional |  | 1005 |  |  |
| dis | dis | Provisional |  | 17134 |  |  |
| dlna-playcontainer | dlna-playcontainer | Provisional |  | 5557 |  | DLNA |
| dlna-playsingle | dlna-playsingle | Provisional |  | 6144 |  | DLNA |
| dnp | dnp | Provisional |  | 15819 |  |  |
| dns | Domain Name System | Permanent |  | 12932 | 4501 | RFC 4501 |
| dntp | dntp | Provisional |  | 14347 |  |  |
| doi | doi | Permanent |  | 13014 |  |  |
| donau | donau | Provisional |  | 10150 |  | draft-grothoff-donau-02 |
| dpp | dpp | Provisional |  | 2442 |  |  |
| drm | drm | Provisional |  | 9859 |  |  |
| drop | drop | Historical |  | 16138 |  | IESG |
| dtmi | dtmi | Provisional |  | 17097 |  |  |
| dtn | DTNRG research and development | Permanent |  | 7456 | 9171 | RFC 9171 |
| dvb | dvb | Provisional |  | 10380 |  | draft-mcroberts-uri-dvb-09 |
| dvx | dvx | Provisional |  | 11645 |  |  |
| dweb | dweb | Provisional |  | 1328 |  |  |
| ed2k | ed2k | Provisional |  | 2790 |  |  |
| eid | eid | Provisional |  | 4929 |  |  |
| elsi | elsi | Provisional |  | 13680 |  |  |
| embedded | embedded | Provisional |  | 4193 |  |  |
| ens | ens | Provisional |  | 1982 |  |  |
| esim | esim | Provisional |  | 3032 |  |  |
| ethereum | ethereum | Provisional |  | 7913 |  |  |
| example | example | Permanent |  | 5296 | 7595 | RFC 7595 |
| ez | ez | Provisional |  | 1010 |  |  |
| facetime | facetime | Provisional |  | 3795 |  |  |
| fax | fax | Historical |  | 4053 | 2806 | RFC 2806; RFC 3966 |
| feed | feed | Provisional |  | 7520 |  |  |
| feedready | feedready | Provisional |  | 11824 |  |  |
| fido | fido | Provisional |  | 5717 |  |  |
| file | Host-specific file names | Permanent |  | 12068 | 8089 | RFC 8089 |
| filesystem | filesystem | Historical |  | 3365 |  |  |
| finger | finger | Provisional |  | 17315 |  |  |
| first-run-pen-experience | first-run-pen-experience | Provisional |  | 16069 |  |  |
| fish | fish | Provisional |  | 12634 |  |  |
| fm | fm | Provisional |  | 2806 |  |  |
| ftp | File Transfer Protocol | Permanent |  | 14878 | 1738 | RFC 1738 |
| fuchsia-pkg | fuchsia-pkg | Provisional |  | 12806 |  | https://fuchsia.googlesource.com/fuchsia/ |
| gcx | gcx | Provisional |  | 1019 |  |  |
| gdsi | gdsi | Provisional |  | 1022 |  |  |
| geo | Geographic Locations | Permanent |  | 3342 | 5870 | RFC 5870 |
| gg | gg | Provisional |  | 11055 |  |  |
| git | git | Provisional |  | 13068 |  |  |
| gitoid | gitoid | Provisional |  | 3775 |  |  |
| gizmoproject | gizmoproject | Provisional |  | 10744 |  |  |
| go | go | Permanent |  | 5705 | 3368 | RFC 3368 |
| gopher | The Gopher Protocol | Permanent |  | 8601 | 4266 | RFC 4266 |
| graph | graph | Provisional |  | 11583 |  |  |
| grd | grd | Historical |  | 9444 |  | IESG |
| gsos | gsos | Provisional |  | 1028 |  | https://www.iana.org/assignments/uri-schemes/prov/gsos.pdf |
| gtalk | gtalk | Provisional |  | 4709 |  |  |
| h323 | H.323 | Permanent |  | 10317 | 3508 | RFC 3508 |
| haie | haie | Provisional |  | 1039 |  | FUTURO ITALIA GARD |
| ham | ham | Provisional |  | 6503 | 7046 | RFC 7046 |
| hcap | hcap | Provisional |  | 9875 |  |  |
| hcp | hcp | Provisional |  | 6024 |  |  |
| hs20 | hs20 | Provisional |  | 1273 |  |  |
| http | Hypertext Transfer Protocol | Permanent | [RFC 8615] | 2 | 9110 | RFC 9110, Section 4.2.1 |
| https | Hypertext Transfer Protocol Secure | Permanent | [RFC 8615] | 3 | 9110 | RFC 9110, Section 4.2.2 |
| hxxp | hxxp | Provisional |  | 16728 |  | draft-salgado-hxxp-01 |
| hxxps | hxxps | Provisional |  | 4714 |  | draft-salgado-hxxp-01 |
| hydrazone | hydrazone | Provisional |  | 6632 |  | https://tech.hydrazone.pro/uri/specification/hydrazone.txt |
| hyper | hyper | Provisional |  | 12876 |  |  |
| i0 | i0 | Provisional |  | 10328 |  |  |
| iax | Inter-Asterisk eXchange Version 2 | Permanent |  | 7126 | 5456 | RFC 5456 |
| ibi | ibi | Provisional |  | 1002 |  |  |
| ibi- | ibi- | Provisional |  | 1003 |  |  |
| icap | Internet Content Adaptation Protocol | Permanent |  | 12566 | 3507 | RFC 3507 |
| icon | icon | Provisional |  | 14868 |  | draft-lafayette-icon-uri-scheme-01 |
| ilstring | ilstring | Provisional |  | 12237 |  | https://webstore.iec.ch/en/publication/77973 |
| im | Instant Messaging | Permanent |  | 6883 | 3860 | RFC 3860 |
| imap | internet message access protocol | Permanent |  | 10119 | 5092 | RFC 5092 |
| info | Information Assets with Identifiers in Public Namespaces. [RFC 4452 (Section 3)] defines an "info" registry of public namespaces, which is maintained by NISO and can be accessed from [http://info-uri.info/]. | Permanent |  | 13846 | 4452 | RFC 4452 |
| interaction | interaction | Provisional |  | 1023 |  |  |
| iotdisco | iotdisco | Provisional |  | 17170 |  | https://www.iana.org/assignments/uri-schemes/prov/iotdisco.pdf |
| ipfs | ipfs | Provisional |  | 15972 |  |  |
| ipn | ipn | Permanent |  | 8775 | 9758 | RFC 9758 |
| ipns | ipns | Provisional |  | 16933 |  |  |
| ipp | Internet Printing Protocol | Permanent |  | 9318 | 3510 | RFC 3510 |
| ipps | Internet Printing Protocol over HTTPS | Permanent |  | 4419 | 7472 | RFC 7472 |
| iqa | iqa | Provisional |  | 28 |  | draft-li-rttp-iqa-addressing-02; https://iqa.org/URI/ |
| irc | irc | Provisional |  | 5425 |  |  |
| irc6 | irc6 | Provisional |  | 1905 |  |  |
| ircs | ircs | Provisional |  | 8687 |  |  |
| iris | Internet Registry Information Service | Permanent |  | 13986 | 3981 | RFC 3981 |
| iris.beep | iris.beep | Permanent |  | 15639 | 3983 | RFC 3983 |
| iris.lwz | iris.lwz | Permanent |  | 4590 | 4993 | RFC 4993 |
| iris.xpc | iris.xpc | Permanent |  | 12422 | 4992 | RFC 4992 |
| iris.xpcs | iris.xpcs | Permanent |  | 16134 | 4992 | RFC 4992 |
| isostore | isostore | Provisional |  | 7225 |  |  |
| itms | itms | Provisional |  | 14830 |  |  |
| jabber | jabber | Permanent |  | 6109 |  |  |
| jar | jar | Provisional |  | 1578 |  |  |
| jms | Java Message Service | Provisional |  | 3634 | 6167 | RFC 6167 |
| keyparc | keyparc | Provisional |  | 9770 |  |  |
| lastfm | lastfm | Provisional |  | 11742 |  |  |
| lbry | lbry | Provisional |  | 14010 |  |  |
| ldap | Lightweight Directory Access Protocol | Permanent |  | 13442 | 4516 | RFC 4516 |
| ldaps | ldaps | Provisional |  | 3906 |  |  |
| leaptofrogans | leaptofrogans | Permanent |  | 16281 | 8589 | RFC 8589 |
| lid | lid | Provisional |  | 10247 |  | IS4 |
| linkid | linkid | Provisional |  | 1819 |  |  |
| locus | locus | Provisional |  | 1029 |  | draft-subthought-locus-uri-scheme-00 |
| lorawan | lorawan | Provisional |  | 11718 |  | OMA-DMSE |
| lpa | lpa | Provisional |  | 6658 |  |  |
| lvlt | lvlt | Provisional |  | 5480 |  |  |
| machineProvisioningProgressReporter | Windows Autopilot Modern Device Management status updates | Provisional |  | 5477 |  |  |
| magnet | magnet | Provisional |  | 9805 |  |  |
| mailserver | Access to data available from mail servers | Historical |  | 10868 | 6196 | RFC 6196 |
| mailto | Electronic mail address | Permanent |  | 12102 | 6068 | RFC 6068 |
| maps | maps | Provisional |  | 14153 |  |  |
| market | market | Provisional |  | 14595 |  |  |
| matrix | matrix | Provisional |  | 9487 |  |  |
| mdoc | mdoc | Provisional |  | 1013 |  | ISO IEC JTC1 SC17 |
| mdoc-openid4vp | mdoc-openid4vp | Provisional |  | 1012 |  | ISO IEC JTC1 SC17 |
| message | message | Provisional |  | 14460 |  |  |
| microsoft.windows.camera | microsoft.windows.camera | Provisional |  | 11857 |  |  |
| microsoft.windows.camera.multipicker | microsoft.windows.camera.multipicker | Provisional |  | 7942 |  |  |
| microsoft.windows.camera.picker | microsoft.windows.camera.picker | Provisional |  | 5883 |  |  |
| mid | message identifier | Permanent |  | 3646 | 2392 | RFC 2392 |
| mms | mms | Provisional |  | 12337 |  |  |
| modem | modem | Historical |  | 9154 | 2806 | RFC 2806; RFC 3966 |
| mongodb | mongodb | Provisional |  | 13372 |  |  |
| moz | moz | Provisional |  | 6808 |  |  |
| mqtt | mqtt | Provisional |  | 10740 |  |  |
| mqtts | mqtts | Provisional |  | 14906 |  |  |
| ms-access | ms-access | Provisional |  | 6863 |  |  |
| ms-appinstaller | ms-appinstaller | Provisional |  | 5152 |  |  |
| ms-browser-extension | ms-browser-extension | Provisional |  | 14090 |  |  |
| ms-calculator | ms-calculator | Provisional |  | 3690 |  |  |
| ms-clicktocommunicate | ms-clicktocommunicate | Provisional |  | 1042 |  |  |
| ms-drive-to | ms-drive-to | Provisional |  | 4102 |  |  |
| ms-enrollment | ms-enrollment | Provisional |  | 14310 |  |  |
| ms-excel | ms-excel | Provisional |  | 5536 |  |  |
| ms-eyecontrolspeech | ms-eyecontrolspeech | Provisional |  | 17381 |  |  |
| ms-gamebarservices | ms-gamebarservices | Provisional |  | 12823 |  |  |
| ms-gamingoverlay | ms-gamingoverlay | Provisional |  | 1059 |  |  |
| ms-getoffice | ms-getoffice | Provisional |  | 14366 |  |  |
| ms-help | ms-help | Provisional |  | 7809 |  |  |
| ms-infopath | ms-infopath | Provisional |  | 8830 |  |  |
| ms-inputapp | ms-inputapp | Provisional |  | 6792 |  |  |
| ms-launchremotedesktop | ms-launchremotedesktop | Provisional |  | 12174 |  |  |
| ms-lockscreencomponent-config | ms-lockscreencomponent-config | Provisional |  | 12525 |  |  |
| ms-media-stream-id | ms-media-stream-id | Provisional |  | 6388 |  |  |
| ms-meetnow | ms-meetnow | Provisional |  | 15645 |  |  |
| ms-mixedrealitycapture | ms-mixedrealitycapture | Provisional |  | 6411 |  |  |
| ms-mobileplans | ms-mobileplans | Provisional |  | 11945 |  |  |
| ms-newsandinterests | ms-newsandinterests | Provisional |  | 2945 |  |  |
| ms-officeapp | ms-officeapp | Provisional |  | 14168 |  |  |
| ms-people | ms-people | Provisional |  | 1528 |  |  |
| ms-personacard | ms-personacard | Provisional |  | 1562 |  |  |
| ms-powerpoint | ms-powerpoint | Provisional |  | 16645 |  |  |
| ms-project | ms-project | Provisional |  | 11130 |  |  |
| ms-publisher | ms-publisher | Provisional |  | 16194 |  |  |
| ms-recall | ms-recall | Provisional |  | 10183 |  |  |
| ms-remotedesktop | ms-remotedesktop | Provisional |  | 5347 |  |  |
| ms-remotedesktop-launch | ms-remotedesktop-launch | Provisional |  | 8085 |  |  |
| ms-restoretabcompanion | ms-restoretabcompanion | Provisional |  | 17175 |  |  |
| ms-screenclip | ms-screenclip | Provisional |  | 10518 |  |  |
| ms-screensketch | ms-screensketch | Provisional |  | 9453 |  |  |
| ms-search | ms-search | Provisional |  | 14034 |  |  |
| ms-search-repair | ms-search-repair | Provisional |  | 15679 |  |  |
| ms-secondary-screen-controller | ms-secondary-screen-controller | Provisional |  | 13098 |  |  |
| ms-secondary-screen-setup | ms-secondary-screen-setup | Provisional |  | 15254 |  |  |
| ms-settings | ms-settings | Provisional |  | 9075 |  |  |
| ms-settings-airplanemode | ms-settings-airplanemode | Provisional |  | 5109 |  |  |
| ms-settings-bluetooth | ms-settings-bluetooth | Provisional |  | 14180 |  |  |
| ms-settings-camera | ms-settings-camera | Provisional |  | 15773 |  |  |
| ms-settings-cellular | ms-settings-cellular | Provisional |  | 15361 |  |  |
| ms-settings-cloudstorage | ms-settings-cloudstorage | Provisional |  | 10640 |  |  |
| ms-settings-connectabledevices | ms-settings-connectabledevices | Provisional |  | 11351 |  |  |
| ms-settings-displays-topology | ms-settings-displays-topology | Provisional |  | 12029 |  |  |
| ms-settings-emailandaccounts | ms-settings-emailandaccounts | Provisional |  | 11072 |  |  |
| ms-settings-language | ms-settings-language | Provisional |  | 9981 |  |  |
| ms-settings-location | ms-settings-location | Provisional |  | 10373 |  |  |
| ms-settings-lock | ms-settings-lock | Provisional |  | 11950 |  |  |
| ms-settings-nfctransactions | ms-settings-nfctransactions | Provisional |  | 10591 |  |  |
| ms-settings-notifications | ms-settings-notifications | Provisional |  | 7868 |  |  |
| ms-settings-power | ms-settings-power | Provisional |  | 13026 |  |  |
| ms-settings-privacy | ms-settings-privacy | Provisional |  | 9198 |  |  |
| ms-settings-proximity | ms-settings-proximity | Provisional |  | 3959 |  |  |
| ms-settings-screenrotation | ms-settings-screenrotation | Provisional |  | 6755 |  |  |
| ms-settings-wifi | ms-settings-wifi | Provisional |  | 15994 |  |  |
| ms-settings-workplace | ms-settings-workplace | Provisional |  | 14936 |  |  |
| ms-spd | ms-spd | Provisional |  | 6189 |  |  |
| ms-stickers | ms-stickers | Provisional |  | 10361 |  |  |
| ms-sttoverlay | ms-sttoverlay | Provisional |  | 5410 |  |  |
| ms-transit-to | ms-transit-to | Provisional |  | 7743 |  |  |
| ms-useractivityset | ms-useractivityset | Provisional |  | 9136 |  |  |
| ms-uup | ms-uup | Provisional |  | 1560 |  |  |
| ms-virtualtouchpad | ms-virtualtouchpad | Provisional |  | 15776 |  |  |
| ms-visio | ms-visio | Provisional |  | 15163 |  |  |
| ms-walk-to | ms-walk-to | Provisional |  | 14364 |  |  |
| ms-whiteboard | ms-whiteboard | Provisional |  | 11467 |  |  |
| ms-whiteboard-cmd | ms-whiteboard-cmd | Provisional |  | 14860 |  |  |
| ms-widgetboard | ms-widgetboard | Provisional |  | 12603 |  |  |
| ms-widgets | ms-widgets | Provisional |  | 4613 |  |  |
| ms-word | ms-word | Provisional |  | 16585 |  |  |
| msnim | msnim | Provisional |  | 8041 |  |  |
| msrp | Message Session Relay Protocol | Permanent |  | 11315 | 4975 | RFC 4975 |
| msrps | Message Session Relay Protocol Secure | Permanent |  | 13440 | 4975 | RFC 4975; RFC 8873 |
| mss | mss | Provisional |  | 12493 |  |  |
| mt | Matter protocol on-boarding payloads that are encoded for use in QR Codes and/or NFC Tags | Permanent |  | 12699 |  |  |
| mtqp | Message Tracking Query Protocol | Permanent |  | 3358 | 3887 | RFC 3887 |
| mtrust | mtrust | Provisional |  | 13062 |  |  |
| mumble | mumble | Provisional |  | 11804 |  |  |
| mupdate | Mailbox Update (MUPDATE) Protocol | Permanent |  | 12569 | 3656 | RFC 3656 |
| musik | musik | Provisional |  | 1014 |  |  |
| mvn | mvn | Provisional |  | 9585 |  |  |
| mvrp | mvrp (see [reviewer notes]) | Provisional |  | 13451 |  |  |
| mvrps | mvrps (see [reviewer notes]) | Provisional |  | 13228 |  |  |
| news | USENET news | Permanent |  | 1895 | 5538 | RFC 5538 |
| nfs | network file system protocol | Permanent |  | 6516 | 2224 | RFC 2224 |
| ni | ni | Permanent |  | 10926 | 6920 | RFC 6920 |
| nih | nih | Permanent |  | 11428 | 6920 | RFC 6920 |
| nntp | USENET news using NNTP access | Permanent |  | 13499 | 5538 | RFC 5538 |
| nostr | nostr | Provisional |  | 1017 |  | https://github.com/nostr-protocol/nostr |
| notes | notes | Provisional |  | 8766 |  | draft-dconmy-notes-uri-scheme-02 |
| npamp | npamp | Provisional |  | 1009 |  | draft-bubblefish-npamp-00 |
| num | Namespace Utility Modules | Provisional |  | 9965 |  | https://www.numprotocol.com/specification |
| ocf | ocf | Provisional |  | 10241 |  |  |
| oid | oid | Provisional |  | 16079 |  | draft-larmouth-oid-iri-04 |
| onenote | onenote | Provisional |  | 13608 |  |  |
| onenote-cmd | onenote-cmd | Provisional |  | 16632 |  |  |
| op | op | Provisional |  | 1040 |  |  |
| opaquelocktoken | opaquelocktokent | Permanent |  | 6341 | 4918 | RFC 4918 |
| openid | OpenID Connect | Provisional |  | 1242 |  |  |
| openpgp4fpr | openpgp4fpr | Provisional |  | 13094 |  |  |
| opns | opns | Provisional |  | 30 |  |  |
| ord | ord | Provisional |  | 256 |  |  |
| ordmail | ordmail | Provisional |  | 257 |  |  |
| otpauth | otpauth | Provisional |  | 13829 |  |  |
| p1 | p1 | Historical |  | 14982 |  | IESG |
| pack | pack | Historical |  | 13348 |  | draft-shur-pack-uri-scheme-05 |
| palm | palm | Provisional |  | 10238 |  |  |
| paparazzi | paparazzi | Provisional |  | 12599 |  |  |
| payment | payment | Historical |  | 1762 |  | IESG |
| payto | payto | Provisional |  | 6992 | 8905 | RFC 8905 |
| pbcp | pbcp | Provisional |  | 1043 |  |  |
| pkcs11 | PKCS#11 | Permanent |  | 9312 | 7512 | RFC 7512 |
| pkg | pkg | Provisional |  | 1018 |  |  |
| platform | platform | Provisional |  | 2754 |  |  |
| pop | Post Office Protocol v3 | Permanent |  | 10551 | 2384 | RFC 2384 |
| pres | Presence | Permanent |  | 14972 | 3859 | RFC 3859 |
| prospero | Prospero Directory Service | Historical |  | 14477 | 4157 | RFC 4157 |
| proxy | proxy | Provisional |  | 3503 |  |  |
| psyc | psyc | Provisional |  | 1466 |  |  |
| pttp | pttp | Provisional |  | 6903 |  |  |
| pwid | pwid | Provisional |  | 17068 |  |  |
| qb | qb | Provisional |  | 12478 |  |  |
| query | query | Provisional |  | 10147 |  |  |
| quic-transport | quic-transport | Provisional |  | 6462 |  | draft-vvv-webtransport-quic-00 |
| redis | redis | Provisional |  | 8099 |  |  |
| rediss | rediss | Provisional |  | 9338 |  |  |
| reload | reload | Permanent |  | 12726 | 6940 | RFC 6940 |
| res | res | Provisional |  | 4153 |  |  |
| resource | resource | Provisional |  | 2284 |  |  |
| rmi | rmi | Provisional |  | 16292 |  |  |
| rsync | rsync | Provisional |  | 16884 | 5781 | RFC 5781 |
| rtmfp | rtmfp | Provisional |  | 3348 | 7425 | RFC 7425 |
| rtmp | rtmp | Provisional |  | 3920 |  |  |
| rtsp | Real-Time Streaming Protocol (RTSP) | Permanent |  | 15267 | 2326 | RFC 2326; RFC 7826 |
| rtsps | Real-Time Streaming Protocol (RTSP) over TLS | Permanent |  | 4619 | 2326 | RFC 2326; RFC 7826 |
| rtspu | Real-Time Streaming Protocol (RTSP) over unreliable datagram transport | Permanent |  | 11999 | 2326 | RFC 2326 |
| rttp | rttp | Provisional |  | 27 |  | draft-li-rttp-iqa-addressing-02; https://rttp.com/URI/ |
| sarif | sarif | Provisional |  | 13650 |  |  |
| secondlife | query | Provisional |  | 16729 |  |  |
| secret-token | secret-token | Provisional |  | 7074 | 8959 | RFC 8959 |
| seki | seki | Provisional |  | 1026 |  |  |
| service | service location | Permanent |  | 17264 | 2609 | RFC 2609 |
| session | session | Permanent |  | 4355 | 6787 | RFC 6787 |
| sftp | query | Provisional |  | 5492 |  |  |
| sgn | sgn | Provisional |  | 4882 |  |  |
| shc | shc | Provisional |  | 5823 |  |  |
| shelter | shelter | Provisional |  | 15461 |  |  |
| shttp | Secure Hypertext Transfer Protocol | Permanent |  | 7874 | 2660 | RFC 2660 |
| sieve | ManageSieve Protocol | Permanent |  | 5472 | 5804 | RFC 5804 |
| simpleledger | simpleledger | Provisional |  | 9544 |  |  |
| simplex | simplex | Provisional |  | 15118 |  |  |
| sip | session initiation protocol | Permanent |  | 12644 | 3261 | RFC 3261 |
| sips | secure session initiation protocol | Permanent |  | 9535 | 3261 | RFC 3261 |
| skype | skype | Provisional |  | 2326 |  |  |
| smb | smb | Provisional |  | 7285 |  |  |
| smp | smp | Provisional |  | 11533 |  |  |
| sms | Short Message Service | Permanent |  | 3524 | 5724 | RFC 5724 |
| smtp | smtp | Provisional |  | 13340 |  | draft-melnikov-smime-msa-to-mda-03 |
| snews | NNTP over SSL/TLS | Historical |  | 13285 | 5538 | RFC 5538 |
| snmp | Simple Network Management Protocol | Permanent |  | 1165 | 4088 | RFC 4088 |
| sns | sns | Provisional |  | 29 |  |  |
| soap.beep | soap.beep | Permanent |  | 8519 | 4227 | RFC 4227 |
| soap.beeps | soap.beeps | Permanent |  | 16300 | 4227 | RFC 4227 |
| soldat | soldat | Provisional |  | 6349 |  |  |
| spacify | spacify | Provisional |  | 1000 |  |  |
| spiffe | spiffe | Provisional |  | 8093 |  |  |
| spotify | spotify | Provisional |  | 12732 |  |  |
| ssb | ssb | Provisional |  | 12400 |  |  |
| ssh | ssh | Provisional |  | 7667 |  |  |
| sss | sss | Provisional |  | 555 |  |  |
| starknet | starknet | Provisional |  | 12458 |  |  |
| steam | steam | Provisional |  | 5134 |  |  |
| stun | stun | Permanent |  | 14627 | 7064 | RFC 7064 |
| stuns | stuns | Permanent |  | 14901 | 7064 | RFC 7064 |
| submit | submit | Provisional |  | 4951 |  | draft-melnikov-smime-msa-to-mda-03 |
| svn | svn | Provisional |  | 13923 |  |  |
| swh | swh | Provisional |  | 17039 |  |  |
| swid | swid (see [reviewer notes]) | Provisional |  | 14162 | 9393 | RFC 9393, Section 5.1 |
| swidpath | swidpath (see [reviewer notes]) | Provisional |  | 5825 | 9393 | RFC 9393, Section 5.2 |
| tag | tag | Permanent |  | 16377 | 4151 | RFC 4151 |
| taler | taler | Provisional |  | 2796 |  | draft-grothoff-taler-01 |
| tcxp | tcxp | Provisional |  | 1030 |  | https://github.com/typed-context-protocol/charter; https://www.w3.org/community/typed-context-protocol/ |
| teamspeak | teamspeak | Provisional |  | 6924 |  |  |
| teapot | teapot | Provisional |  | 15026 |  |  |
| teapots | teapots | Provisional |  | 3375 |  |  |
| tel | telephone | Permanent |  | 3143 | 3966 | RFC 3966; RFC 5341 |
| teliaeid | teliaeid | Provisional |  | 13362 |  |  |
| telnet | Reference to interactive sessions | Permanent |  | 10995 | 4248 | RFC 4248 |
| tftp | Trivial File Transfer Protocol | Permanent |  | 8300 | 3617 | RFC 3617 |
| things | things | Provisional |  | 2154 |  |  |
| thismessage | multipart/related relative reference resolution | Permanent |  | 14367 | 2557 | RFC 2557 |
| thzp | thzp | Historical |  | 11820 |  | IESG |
| tii | tii | Provisional |  | 1027 |  |  |
| tip | Transaction Internet Protocol | Permanent |  | 6651 | 2371 | RFC 2371 |
| tn3270 | Interactive 3270 emulation sessions | Permanent |  | 14962 | 6270 | RFC 6270 |
| tool | tool | Provisional |  | 15230 |  |  |
| tttps | TLS TimeToken Secure Protocol (TTTPS). A cryptographic temporal ordering proof protocol augmenting TLS 1.3 with Proof-of-Time records. | Provisional |  | 1011 |  | draft-helmprotocol-tttps-04 |
| turn | turn | Permanent |  | 10333 | 7065 | RFC 7065 |
| turns | turns | Permanent |  | 1926 | 7065 | RFC 7065 |
| tv | TV Broadcasts | Permanent |  | 7923 | 2838 | RFC 2838 |
| udp | udp | Provisional |  | 5217 |  |  |
| unreal | unreal | Provisional |  | 15206 |  |  |
| upn | upn | Provisional |  | 1004 |  |  |
| upt | upt | Historical |  | 2747 |  | IESG |
| urn | Uniform Resource Names | Permanent |  | 4 | 8141 | RFC 8141 |
| ust | ust | Provisional |  | 1016 |  | THE LAB; https://github.com/thelabmd/UST-Protocol/blob/main/spec/UST-1.0.md |
| ut2004 | ut2004 | Provisional |  | 6609 |  |  |
| uuaid | uuaid | Provisional |  | 1015 |  |  |
| uuid-in-package | uuid-in-package | Provisional |  | 4515 |  |  |
| v-event | v-event | Provisional |  | 15579 |  | draft-menderico-v-event-uri-00 |
| vemmi | versatile multimedia interface | Permanent |  | 16918 | 2122 | RFC 2122 |
| ventrilo | ventrilo | Provisional |  | 12502 |  |  |
| ves | ves | Provisional |  | 10176 |  |  |
| videotex | videotex | Historical |  | 2406 | 2122 | draft-mavrakis-videotex-url-spec-01; RFC 2122; RFC 3986 |
| view-source | view-source | Provisional |  | 8506 |  |  |
| vnc | Remote Framebuffer Protocol | Permanent |  | 11537 | 7869 | RFC 7869 |
| vscode | vscode | Provisional |  | 7812 |  |  |
| vscode-insiders | vscode-insiders | Provisional |  | 3255 |  |  |
| vsls | vsls | Provisional |  | 9816 |  |  |
| w3 | w3 (see [reviewer notes]) | Provisional |  | 11799 |  |  |
| wais | Wide Area Information Servers | Historical |  | 8454 | 4156 | RFC 4156 |
| wasm | wasm | Provisional |  | 15741 |  |  |
| wasm-js | wasm-js | Provisional |  | 14709 |  |  |
| wcr | wcr | Provisional |  | 11892 |  |  |
| web+ap | web+ap | Provisional |  | 17361 |  |  |
| web+interaction | web+interaction | Provisional |  | 1024 |  |  |
| web3 | web3 | Provisional |  | 4559 |  |  |
| webcal | webcal | Provisional |  | 4183 |  |  |
| wifi | wifi | Provisional |  | 14867 |  |  |
| wpid | wpid | Historical |  | 1658 |  |  |
| ws | WebSocket connections | Permanent | [RFC 8307] | 11962 | 6455 | RFC 6455 |
| wss | Encrypted WebSocket connections | Permanent | [RFC 8307] | 3119 | 6455 | RFC 6455 |
| wtai | wtai | Provisional |  | 9910 |  |  |
| wyciwyg | wyciwyg | Provisional |  | 15641 |  |  |
| xcompute | xcompute | Provisional |  | 13785 |  |  |
| xcon | xcon | Permanent |  | 10467 | 6501 | RFC 6501 |
| xcon-userid | xcon-userid | Permanent |  | 9520 | 6501 | RFC 6501 |
| xfire | xfire | Provisional |  | 15306 |  |  |
| xftp | xftp | Provisional |  | 4315 |  |  |
| xmlrpc.beep | xmlrpc.beep | Permanent |  | 3005 | 3529 | RFC 3529 |
| xmlrpc.beeps | xmlrpc.beeps | Permanent |  | 15805 | 3529 | RFC 3529 |
| xmpp | Extensible Messaging and Presence Protocol | Permanent |  | 15358 | 5122 | RFC 5122 |
| xrcp | xrcp | Provisional |  | 4747 |  |  |
| xri | xri | Provisional |  | 11255 |  |  |
| xudanu | xudanu | Provisional |  | 1041 |  |  |
| ymsgr | ymsgr | Provisional |  | 3837 |  |  |
| z39.50 | Z39.50 information access | Historical |  | 1319 | 1738 | RFC 1738; RFC 2056 |
| z39.50r | Z39.50 Retrieval | Permanent |  | 8159 | 2056 | RFC 2056 |
| z39.50s | Z39.50 Session | Permanent |  | 6380 | 2056 | RFC 2056 |
| ztdnaid | ztdnaid | Provisional |  | 1008 |  |  |

Source: https://aidb.si/d/uri-schemes — Source: Internet Assigned Numbers Authority (IANA), URI Schemes registry.

