URI schemes (IANA registry)

Source: https://aidb.si/d/uri-schemes — Source: Internet Assigned Numbers Authority (IANA), URI Schemes registry.

SchemeDescriptionStatusWell-known URIsCRI scheme numberDefining RFCReferences
aaaDiameter ProtocolPermanent138626733RFC 6733
aaasDiameter Protocol with Secure TransportPermanent145266733RFC 6733
aboutaboutPermanent37866694RFC 6694
acapapplication configuration access protocolPermanent127052244RFC 2244
acctacctPermanent102297565RFC 7565
acdacdProvisional6840
aceaceProvisional26
aceapaceapProvisional1034
acedpacedpProvisional1035
aceepaceepProvisional1036
acelpacelpProvisional1037
aceupaceupProvisional1038
acracrProvisional10196OMA-OMNA
adiumxtraadiumxtraProvisional6634
adtadtProvisional5150SAP SE
aetaetProvisional1020
afpafpProvisional13404
afsAndrew File System global file namesProvisional106871738RFC 1738
agtpagtpProvisional1006
aimaimProvisional10327
alteralterProvisional1031draft-morrison-alter-uri-scheme-03
amssamssProvisional10831
androidandroidProvisional15061https://developer.android.com/guide/topics/manifest/manifest-intro
appdataappdataProvisional7364
aptaptProvisional7856
ararProvisional5099
ariariProvisional3818draft-ietf-dtn-ari-04
arkarkProvisional3018https://n2t.net/ark:/21206/10015
arsarsProvisional1025draft-juwan-ars-uri-00
arvarvProvisional1032
atat (see [reviewer notes])Provisional6007
attachmentattachmentProvisional8577
awawProvisional16051
barionbarionProvisional10225
bbbbHistorical5188IESG
besharebeshareProvisional4674
bitcoinbitcoinProvisional9186
bitcoincashbitcoincashProvisional7226
blbluetooth (shortened)Provisional10024
blobblobProvisional11060
bluetoothbluetoothProvisional12052
boloboloProvisional8765
bridbridProvisional8251
browserextbrowserextProvisional4327
cabalcabalProvisional11393
caipcaipProvisional1001
calculatorcalculatorProvisional3783
calltocalltoProvisional8713
canactidcanactidProvisional1033draft-schrock-canonical-action-identifier-05
capCalendar Access ProtocolPermanent92044324RFC 4324
castcastProvisional1220https://developers.google.com/cast/docs/registration
castscastsProvisional12718https://developers.google.com/cast/docs/registration
chromechromeProvisional5728
chrome-extensionchrome-extensionProvisional14667
cidcontent identifierPermanent152022392RFC 2392
cmcmProvisional1021
coapcoapPermanent[RFC 7252]07252RFC 7252
coap+tcpcoap+tcp (see [reviewer notes])Permanent[RFC 8323]68323RFC 8323
coap+wscoap+ws (see [reviewer notes])Permanent[RFC 8323]248323RFC 8323
coapscoapsPermanent[RFC 7252]17252RFC 7252
coaps+tcpcoaps+tcp (see [reviewer notes])Permanent[RFC 8323]78323RFC 8323
coaps+wscoaps+ws (see [reviewer notes])Permanent[RFC 8323]258323RFC 8323
com-eventbrite-attendeecom-eventbrite-attendeeProvisional9278
contentcontentProvisional8387
content-typecontent-typeProvisional6030
cridTV-Anytime Content Reference IdentifierPermanent59904078RFC 4078
cstrcstrProvisional6730
cttpscttpsProvisional1007
cvscvsProvisional12242
dabdabProvisional6774
datdatProvisional10583
datadataPermanent19462397RFC 2397
davdavPermanent43734918RFC 4918
dhttpdhttp (see [reviewer notes])Provisional4549
diasporadiasporaProvisional4598
dictdictionary service protocolPermanent38862229RFC 2229
diddidProvisional5
dilithium3dilithium3Provisional1005
disdisProvisional17134
dlna-playcontainerdlna-playcontainerProvisional5557DLNA
dlna-playsingledlna-playsingleProvisional6144DLNA
dnpdnpProvisional15819
dnsDomain Name SystemPermanent129324501RFC 4501
dntpdntpProvisional14347
doidoiPermanent13014
donaudonauProvisional10150draft-grothoff-donau-02
dppdppProvisional2442
drmdrmProvisional9859
dropdropHistorical16138IESG
dtmidtmiProvisional17097
dtnDTNRG research and developmentPermanent74569171RFC 9171
dvbdvbProvisional10380draft-mcroberts-uri-dvb-09
dvxdvxProvisional11645
dwebdwebProvisional1328
ed2ked2kProvisional2790
eideidProvisional4929
elsielsiProvisional13680
embeddedembeddedProvisional4193
ensensProvisional1982
esimesimProvisional3032
ethereumethereumProvisional7913
exampleexamplePermanent52967595RFC 7595
ezezProvisional1010
facetimefacetimeProvisional3795
faxfaxHistorical40532806RFC 2806; RFC 3966
feedfeedProvisional7520
feedreadyfeedreadyProvisional11824
fidofidoProvisional5717
fileHost-specific file namesPermanent120688089RFC 8089
filesystemfilesystemHistorical3365
fingerfingerProvisional17315
first-run-pen-experiencefirst-run-pen-experienceProvisional16069
fishfishProvisional12634
fmfmProvisional2806
ftpFile Transfer ProtocolPermanent148781738RFC 1738
fuchsia-pkgfuchsia-pkgProvisional12806https://fuchsia.googlesource.com/fuchsia/
gcxgcxProvisional1019
gdsigdsiProvisional1022
geoGeographic LocationsPermanent33425870RFC 5870
ggggProvisional11055
gitgitProvisional13068
gitoidgitoidProvisional3775
gizmoprojectgizmoprojectProvisional10744
gogoPermanent57053368RFC 3368
gopherThe Gopher ProtocolPermanent86014266RFC 4266
graphgraphProvisional11583
grdgrdHistorical9444IESG
gsosgsosProvisional1028https://www.iana.org/assignments/uri-schemes/prov/gsos.pdf
gtalkgtalkProvisional4709
h323H.323Permanent103173508RFC 3508
haiehaieProvisional1039FUTURO ITALIA GARD
hamhamProvisional65037046RFC 7046
hcaphcapProvisional9875
hcphcpProvisional6024
hs20hs20Provisional1273
httpHypertext Transfer ProtocolPermanent[RFC 8615]29110RFC 9110, Section 4.2.1
httpsHypertext Transfer Protocol SecurePermanent[RFC 8615]39110RFC 9110, Section 4.2.2
hxxphxxpProvisional16728draft-salgado-hxxp-01
hxxpshxxpsProvisional4714draft-salgado-hxxp-01
hydrazonehydrazoneProvisional6632https://tech.hydrazone.pro/uri/specification/hydrazone.txt
hyperhyperProvisional12876
i0i0Provisional10328
iaxInter-Asterisk eXchange Version 2Permanent71265456RFC 5456
ibiibiProvisional1002
ibi-ibi-Provisional1003
icapInternet Content Adaptation ProtocolPermanent125663507RFC 3507
iconiconProvisional14868draft-lafayette-icon-uri-scheme-01
ilstringilstringProvisional12237https://webstore.iec.ch/en/publication/77973
imInstant MessagingPermanent68833860RFC 3860
imapinternet message access protocolPermanent101195092RFC 5092
infoInformation Assets with Identifiers in Public Namespaces. [RFC 4452 (Section 3)] defines an "info" registry of public namespaces, which is maintained by NISO and can be accessed from [http://info-uri.info/].Permanent138464452RFC 4452
interactioninteractionProvisional1023
iotdiscoiotdiscoProvisional17170https://www.iana.org/assignments/uri-schemes/prov/iotdisco.pdf
ipfsipfsProvisional15972
ipnipnPermanent87759758RFC 9758
ipnsipnsProvisional16933
ippInternet Printing ProtocolPermanent93183510RFC 3510
ippsInternet Printing Protocol over HTTPSPermanent44197472RFC 7472
iqaiqaProvisional28draft-li-rttp-iqa-addressing-02; https://iqa.org/URI/
ircircProvisional5425
irc6irc6Provisional1905
ircsircsProvisional8687
irisInternet Registry Information ServicePermanent139863981RFC 3981
iris.beepiris.beepPermanent156393983RFC 3983
iris.lwziris.lwzPermanent45904993RFC 4993
iris.xpciris.xpcPermanent124224992RFC 4992
iris.xpcsiris.xpcsPermanent161344992RFC 4992
isostoreisostoreProvisional7225
itmsitmsProvisional14830
jabberjabberPermanent6109
jarjarProvisional1578
jmsJava Message ServiceProvisional36346167RFC 6167
keyparckeyparcProvisional9770
lastfmlastfmProvisional11742
lbrylbryProvisional14010
ldapLightweight Directory Access ProtocolPermanent134424516RFC 4516
ldapsldapsProvisional3906
leaptofrogansleaptofrogansPermanent162818589RFC 8589
lidlidProvisional10247IS4
linkidlinkidProvisional1819
locuslocusProvisional1029draft-subthought-locus-uri-scheme-00
lorawanlorawanProvisional11718OMA-DMSE
lpalpaProvisional6658
lvltlvltProvisional5480
machineProvisioningProgressReporterWindows Autopilot Modern Device Management status updatesProvisional5477
magnetmagnetProvisional9805
mailserverAccess to data available from mail serversHistorical108686196RFC 6196
mailtoElectronic mail addressPermanent121026068RFC 6068
mapsmapsProvisional14153
marketmarketProvisional14595
matrixmatrixProvisional9487
mdocmdocProvisional1013ISO IEC JTC1 SC17
mdoc-openid4vpmdoc-openid4vpProvisional1012ISO IEC JTC1 SC17
messagemessageProvisional14460
microsoft.windows.cameramicrosoft.windows.cameraProvisional11857
microsoft.windows.camera.multipickermicrosoft.windows.camera.multipickerProvisional7942
microsoft.windows.camera.pickermicrosoft.windows.camera.pickerProvisional5883
midmessage identifierPermanent36462392RFC 2392
mmsmmsProvisional12337
modemmodemHistorical91542806RFC 2806; RFC 3966
mongodbmongodbProvisional13372
mozmozProvisional6808
mqttmqttProvisional10740
mqttsmqttsProvisional14906
ms-accessms-accessProvisional6863
ms-appinstallerms-appinstallerProvisional5152
ms-browser-extensionms-browser-extensionProvisional14090
ms-calculatorms-calculatorProvisional3690
ms-clicktocommunicatems-clicktocommunicateProvisional1042
ms-drive-toms-drive-toProvisional4102
ms-enrollmentms-enrollmentProvisional14310
ms-excelms-excelProvisional5536
ms-eyecontrolspeechms-eyecontrolspeechProvisional17381
ms-gamebarservicesms-gamebarservicesProvisional12823
ms-gamingoverlayms-gamingoverlayProvisional1059
ms-getofficems-getofficeProvisional14366
ms-helpms-helpProvisional7809
ms-infopathms-infopathProvisional8830
ms-inputappms-inputappProvisional6792
ms-launchremotedesktopms-launchremotedesktopProvisional12174
ms-lockscreencomponent-configms-lockscreencomponent-configProvisional12525
ms-media-stream-idms-media-stream-idProvisional6388
ms-meetnowms-meetnowProvisional15645
ms-mixedrealitycapturems-mixedrealitycaptureProvisional6411
ms-mobileplansms-mobileplansProvisional11945
ms-newsandinterestsms-newsandinterestsProvisional2945
ms-officeappms-officeappProvisional14168
ms-peoplems-peopleProvisional1528
ms-personacardms-personacardProvisional1562
ms-powerpointms-powerpointProvisional16645
ms-projectms-projectProvisional11130
ms-publisherms-publisherProvisional16194
ms-recallms-recallProvisional10183
ms-remotedesktopms-remotedesktopProvisional5347
ms-remotedesktop-launchms-remotedesktop-launchProvisional8085
ms-restoretabcompanionms-restoretabcompanionProvisional17175
ms-screenclipms-screenclipProvisional10518
ms-screensketchms-screensketchProvisional9453
ms-searchms-searchProvisional14034
ms-search-repairms-search-repairProvisional15679
ms-secondary-screen-controllerms-secondary-screen-controllerProvisional13098
ms-secondary-screen-setupms-secondary-screen-setupProvisional15254
ms-settingsms-settingsProvisional9075
ms-settings-airplanemodems-settings-airplanemodeProvisional5109
ms-settings-bluetoothms-settings-bluetoothProvisional14180
ms-settings-camerams-settings-cameraProvisional15773
ms-settings-cellularms-settings-cellularProvisional15361
ms-settings-cloudstoragems-settings-cloudstorageProvisional10640
ms-settings-connectabledevicesms-settings-connectabledevicesProvisional11351
ms-settings-displays-topologyms-settings-displays-topologyProvisional12029
ms-settings-emailandaccountsms-settings-emailandaccountsProvisional11072
ms-settings-languagems-settings-languageProvisional9981
ms-settings-locationms-settings-locationProvisional10373
ms-settings-lockms-settings-lockProvisional11950
ms-settings-nfctransactionsms-settings-nfctransactionsProvisional10591
ms-settings-notificationsms-settings-notificationsProvisional7868
ms-settings-powerms-settings-powerProvisional13026
ms-settings-privacyms-settings-privacyProvisional9198
ms-settings-proximityms-settings-proximityProvisional3959
ms-settings-screenrotationms-settings-screenrotationProvisional6755
ms-settings-wifims-settings-wifiProvisional15994
ms-settings-workplacems-settings-workplaceProvisional14936
ms-spdms-spdProvisional6189
ms-stickersms-stickersProvisional10361
ms-sttoverlayms-sttoverlayProvisional5410
ms-transit-toms-transit-toProvisional7743
ms-useractivitysetms-useractivitysetProvisional9136
ms-uupms-uupProvisional1560
ms-virtualtouchpadms-virtualtouchpadProvisional15776
ms-visioms-visioProvisional15163
ms-walk-toms-walk-toProvisional14364
ms-whiteboardms-whiteboardProvisional11467
ms-whiteboard-cmdms-whiteboard-cmdProvisional14860
ms-widgetboardms-widgetboardProvisional12603
ms-widgetsms-widgetsProvisional4613
ms-wordms-wordProvisional16585
msnimmsnimProvisional8041
msrpMessage Session Relay ProtocolPermanent113154975RFC 4975
msrpsMessage Session Relay Protocol SecurePermanent134404975RFC 4975; RFC 8873
mssmssProvisional12493
mtMatter protocol on-boarding payloads that are encoded for use in QR Codes and/or NFC TagsPermanent12699
mtqpMessage Tracking Query ProtocolPermanent33583887RFC 3887
mtrustmtrustProvisional13062
mumblemumbleProvisional11804
mupdateMailbox Update (MUPDATE) ProtocolPermanent125693656RFC 3656
musikmusikProvisional1014
mvnmvnProvisional9585
mvrpmvrp (see [reviewer notes])Provisional13451
mvrpsmvrps (see [reviewer notes])Provisional13228
newsUSENET newsPermanent18955538RFC 5538
nfsnetwork file system protocolPermanent65162224RFC 2224
niniPermanent109266920RFC 6920
nihnihPermanent114286920RFC 6920
nntpUSENET news using NNTP accessPermanent134995538RFC 5538
nostrnostrProvisional1017https://github.com/nostr-protocol/nostr
notesnotesProvisional8766draft-dconmy-notes-uri-scheme-02
npampnpampProvisional1009draft-bubblefish-npamp-00
numNamespace Utility ModulesProvisional9965https://www.numprotocol.com/specification
ocfocfProvisional10241
oidoidProvisional16079draft-larmouth-oid-iri-04
onenoteonenoteProvisional13608
onenote-cmdonenote-cmdProvisional16632
opopProvisional1040
opaquelocktokenopaquelocktokentPermanent63414918RFC 4918
openidOpenID ConnectProvisional1242
openpgp4fpropenpgp4fprProvisional13094
opnsopnsProvisional30
ordordProvisional256
ordmailordmailProvisional257
otpauthotpauthProvisional13829
p1p1Historical14982IESG
packpackHistorical13348draft-shur-pack-uri-scheme-05
palmpalmProvisional10238
paparazzipaparazziProvisional12599
paymentpaymentHistorical1762IESG
paytopaytoProvisional69928905RFC 8905
pbcppbcpProvisional1043
pkcs11PKCS#11Permanent93127512RFC 7512
pkgpkgProvisional1018
platformplatformProvisional2754
popPost Office Protocol v3Permanent105512384RFC 2384
presPresencePermanent149723859RFC 3859
prosperoProspero Directory ServiceHistorical144774157RFC 4157
proxyproxyProvisional3503
psycpsycProvisional1466
pttppttpProvisional6903
pwidpwidProvisional17068
qbqbProvisional12478
queryqueryProvisional10147
quic-transportquic-transportProvisional6462draft-vvv-webtransport-quic-00
redisredisProvisional8099
redissredissProvisional9338
reloadreloadPermanent127266940RFC 6940
resresProvisional4153
resourceresourceProvisional2284
rmirmiProvisional16292
rsyncrsyncProvisional168845781RFC 5781
rtmfprtmfpProvisional33487425RFC 7425
rtmprtmpProvisional3920
rtspReal-Time Streaming Protocol (RTSP)Permanent152672326RFC 2326; RFC 7826
rtspsReal-Time Streaming Protocol (RTSP) over TLSPermanent46192326RFC 2326; RFC 7826
rtspuReal-Time Streaming Protocol (RTSP) over unreliable datagram transportPermanent119992326RFC 2326
rttprttpProvisional27draft-li-rttp-iqa-addressing-02; https://rttp.com/URI/
sarifsarifProvisional13650
secondlifequeryProvisional16729
secret-tokensecret-tokenProvisional70748959RFC 8959
sekisekiProvisional1026
serviceservice locationPermanent172642609RFC 2609
sessionsessionPermanent43556787RFC 6787
sftpqueryProvisional5492
sgnsgnProvisional4882
shcshcProvisional5823
sheltershelterProvisional15461
shttpSecure Hypertext Transfer ProtocolPermanent78742660RFC 2660
sieveManageSieve ProtocolPermanent54725804RFC 5804
simpleledgersimpleledgerProvisional9544
simplexsimplexProvisional15118
sipsession initiation protocolPermanent126443261RFC 3261
sipssecure session initiation protocolPermanent95353261RFC 3261
skypeskypeProvisional2326
smbsmbProvisional7285
smpsmpProvisional11533
smsShort Message ServicePermanent35245724RFC 5724
smtpsmtpProvisional13340draft-melnikov-smime-msa-to-mda-03
snewsNNTP over SSL/TLSHistorical132855538RFC 5538
snmpSimple Network Management ProtocolPermanent11654088RFC 4088
snssnsProvisional29
soap.beepsoap.beepPermanent85194227RFC 4227
soap.beepssoap.beepsPermanent163004227RFC 4227
soldatsoldatProvisional6349
spacifyspacifyProvisional1000
spiffespiffeProvisional8093
spotifyspotifyProvisional12732
ssbssbProvisional12400
sshsshProvisional7667
ssssssProvisional555
starknetstarknetProvisional12458
steamsteamProvisional5134
stunstunPermanent146277064RFC 7064
stunsstunsPermanent149017064RFC 7064
submitsubmitProvisional4951draft-melnikov-smime-msa-to-mda-03
svnsvnProvisional13923
swhswhProvisional17039
swidswid (see [reviewer notes])Provisional141629393RFC 9393, Section 5.1
swidpathswidpath (see [reviewer notes])Provisional58259393RFC 9393, Section 5.2
tagtagPermanent163774151RFC 4151
talertalerProvisional2796draft-grothoff-taler-01
tcxptcxpProvisional1030https://github.com/typed-context-protocol/charter; https://www.w3.org/community/typed-context-protocol/
teamspeakteamspeakProvisional6924
teapotteapotProvisional15026
teapotsteapotsProvisional3375
teltelephonePermanent31433966RFC 3966; RFC 5341
teliaeidteliaeidProvisional13362
telnetReference to interactive sessionsPermanent109954248RFC 4248
tftpTrivial File Transfer ProtocolPermanent83003617RFC 3617
thingsthingsProvisional2154
thismessagemultipart/related relative reference resolutionPermanent143672557RFC 2557
thzpthzpHistorical11820IESG
tiitiiProvisional1027
tipTransaction Internet ProtocolPermanent66512371RFC 2371
tn3270Interactive 3270 emulation sessionsPermanent149626270RFC 6270
tooltoolProvisional15230
tttpsTLS TimeToken Secure Protocol (TTTPS). A cryptographic temporal ordering proof protocol augmenting TLS 1.3 with Proof-of-Time records.Provisional1011draft-helmprotocol-tttps-04
turnturnPermanent103337065RFC 7065
turnsturnsPermanent19267065RFC 7065
tvTV BroadcastsPermanent79232838RFC 2838
udpudpProvisional5217
unrealunrealProvisional15206
upnupnProvisional1004
uptuptHistorical2747IESG
urnUniform Resource NamesPermanent48141RFC 8141
ustustProvisional1016THE LAB; https://github.com/thelabmd/UST-Protocol/blob/main/spec/UST-1.0.md
ut2004ut2004Provisional6609
uuaiduuaidProvisional1015
uuid-in-packageuuid-in-packageProvisional4515
v-eventv-eventProvisional15579draft-menderico-v-event-uri-00
vemmiversatile multimedia interfacePermanent169182122RFC 2122
ventriloventriloProvisional12502
vesvesProvisional10176
videotexvideotexHistorical24062122draft-mavrakis-videotex-url-spec-01; RFC 2122; RFC 3986
view-sourceview-sourceProvisional8506
vncRemote Framebuffer ProtocolPermanent115377869RFC 7869
vscodevscodeProvisional7812
vscode-insidersvscode-insidersProvisional3255
vslsvslsProvisional9816
w3w3 (see [reviewer notes])Provisional11799
waisWide Area Information ServersHistorical84544156RFC 4156
wasmwasmProvisional15741
wasm-jswasm-jsProvisional14709
wcrwcrProvisional11892
web+apweb+apProvisional17361
web+interactionweb+interactionProvisional1024
web3web3Provisional4559
webcalwebcalProvisional4183
wifiwifiProvisional14867
wpidwpidHistorical1658
wsWebSocket connectionsPermanent[RFC 8307]119626455RFC 6455
wssEncrypted WebSocket connectionsPermanent[RFC 8307]31196455RFC 6455
wtaiwtaiProvisional9910
wyciwygwyciwygProvisional15641
xcomputexcomputeProvisional13785
xconxconPermanent104676501RFC 6501
xcon-useridxcon-useridPermanent95206501RFC 6501
xfirexfireProvisional15306
xftpxftpProvisional4315
xmlrpc.beepxmlrpc.beepPermanent30053529RFC 3529
xmlrpc.beepsxmlrpc.beepsPermanent158053529RFC 3529
xmppExtensible Messaging and Presence ProtocolPermanent153585122RFC 5122
xrcpxrcpProvisional4747
xrixriProvisional11255
xudanuxudanuProvisional1041
ymsgrymsgrProvisional3837
z39.50Z39.50 information accessHistorical13191738RFC 1738; RFC 2056
z39.50rZ39.50 RetrievalPermanent81592056RFC 2056
z39.50sZ39.50 SessionPermanent63802056RFC 2056
ztdnaidztdnaidProvisional1008