Character sets and encodings (IANA registry)

Source: https://aidb.si/d/iana-character-sets — Source: Internet Assigned Numbers Authority (IANA), Character Sets registry.

MIBenumNamePreferred MIME nameAliasesAlias namesSourceReferences
3US-ASCIIUS-ASCII9iso-ir-6; ANSI_X3.4-1968; ANSI_X3.4-1986; ISO_646.irv:1991; ISO646-US; us; IBM367; cp367; csASCIIANSI X3.4-1986RFC 2046
4ISO_8859-1:1987ISO-8859-18iso-ir-100; ISO_8859-1; ISO-8859-1; latin1; l1; IBM819; CP819; csISOLatin1[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
5ISO_8859-2:1987ISO-8859-26iso-ir-101; ISO_8859-2; ISO-8859-2; latin2; l2; csISOLatin2[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
6ISO_8859-3:1988ISO-8859-36iso-ir-109; ISO_8859-3; ISO-8859-3; latin3; l3; csISOLatin3[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
7ISO_8859-4:1988ISO-8859-46iso-ir-110; ISO_8859-4; ISO-8859-4; latin4; l4; csISOLatin4[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
8ISO_8859-5:1988ISO-8859-55iso-ir-144; ISO_8859-5; ISO-8859-5; cyrillic; csISOLatinCyrillic[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
9ISO_8859-6:1987ISO-8859-67iso-ir-127; ISO_8859-6; ISO-8859-6; ECMA-114; ASMO-708; arabic; csISOLatinArabic[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
10ISO_8859-7:1987ISO-8859-78iso-ir-126; ISO_8859-7; ISO-8859-7; ELOT_928; ECMA-118; greek; greek8; csISOLatinGreek[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1947; RFC 1345
11ISO_8859-8:1988ISO-8859-85iso-ir-138; ISO_8859-8; ISO-8859-8; hebrew; csISOLatinHebrew[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
12ISO_8859-9:1989ISO-8859-96iso-ir-148; ISO_8859-9; ISO-8859-9; latin5; l5; csISOLatin5[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
13ISO-8859-10ISO-8859-105iso-ir-157; l6; ISO_8859-10:1992; csISOLatin6; latin6[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
14ISO_6937-2-add2iso-ir-142; csISOTextComm[ISO-IR: International Register of Escape Sequences] and ISO 6937-2:1983 Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
15JIS_X02012X0201; csHalfWidthKatakanaJIS X 0201-1976. One byte only, this is equivalent to JIS/Roman (similar to ASCII) plus eight-bit half-width KatakanaRFC 1345
16JIS_Encoding1csJISEncodingJIS X 0202-1991. Uses ISO 2022 escape sequences to shift code sets as documented in JIS X 0202-1991.
17Shift_JISShift_JIS2MS_Kanji; csShiftJISThis charset is an extension of csHalfWidthKatakana by adding graphic characters in JIS X 0208. The CCS's are JIS X0201:1997 and JIS X0208:1997. The complete definition is shown in Appendix 1 of JIS X0208:1997. This charset can be used for the top-level media type "text".
18Extended_UNIX_Code_Packed_Format_for_JapaneseEUC-JP2csEUCPkdFmtJapanese; EUC-JPStandardized by OSF, UNIX International, and UNIX Systems Laboratories Pacific. Uses ISO 2022 rules to select code set 0: US-ASCII (a single 7-bit byte set) code set 1: JIS X0208-1990 (a double 8-bit byte set) restricted to A0-FF in both bytes code set 2: Half Width Katakana (a single 7-bit byte set) requiring SS2 as the character prefix code set 3: JIS X0212-1990 (a double 7-bit byte set) restricted to A0-FF in both bytes requiring SS3 as the character prefix
19Extended_UNIX_Code_Fixed_Width_for_Japanese1csEUCFixWidJapaneseUsed in Japan. Each character is 2 octets. code set 0: US-ASCII (a single 7-bit byte set) 1st byte = 00 2nd byte = 20-7E code set 1: JIS X0208-1990 (a double 7-bit byte set) restricted to A0-FF in both bytes code set 2: Half Width Katakana (a single 7-bit byte set) 1st byte = 00 2nd byte = A0-FF code set 3: JIS X0212-1990 (a double 7-bit byte set) restricted to A0-FF in the first byte and 21-7E in the second byte
20BS_47305iso-ir-4; ISO646-GB; gb; uk; csISO4UnitedKingdom[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
21SEN_850200_C4iso-ir-11; ISO646-SE2; se2; csISO11SwedishForNames[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
22IT3iso-ir-15; ISO646-IT; csISO15Italian[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
23ES3iso-ir-17; ISO646-ES; csISO17Spanish[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
24DIN_660034iso-ir-21; de; ISO646-DE; csISO21German[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
25NS_4551-15iso-ir-60; ISO646-NO; no; csISO60DanishNorwegian; csISO60Norwegian1[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
26NF_Z_62-0104iso-ir-69; ISO646-FR; fr; csISO69French[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
27ISO-10646-UTF-11csISO10646UTF1Universal Transfer Format (1), this is the multibyte encoding, that subsets ASCII-7. It does not have byte ordering issues.
28ISO_646.basic:19832ref; csISO646basic1983[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
29INVARIANT1csINVARIANTRFC 1345
30ISO_646.irv:19833iso-ir-2; irv; csISO2IntlRefVersion[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
31NATS-SEFI2iso-ir-8-1; csNATSSEFI[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
32NATS-SEFI-ADD2iso-ir-8-2; csNATSSEFIADD[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
33NATS-DANO2iso-ir-9-1; csNATSDANO[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
34NATS-DANO-ADD2iso-ir-9-2; csNATSDANOADD[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
35SEN_850200_B6iso-ir-10; FI; ISO646-FI; ISO646-SE; se; csISO10Swedish[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
36KS_C_5601-19875iso-ir-149; KS_C_5601-1989; KSC_5601; korean; csKSC56011987[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
37ISO-2022-KRISO-2022-KR1csISO2022KR[RFC 1557] (see also KS_C_5601-1987)RFC 1557
38EUC-KREUC-KR1csEUCKR[RFC 1557] (see also KS_C_5861-1992)RFC 1557
39ISO-2022-JPISO-2022-JP1csISO2022JP[RFC 1468] (see also [RFC 2237])RFC 1468
40ISO-2022-JP-2ISO-2022-JP-21csISO2022JP2[RFC 1554]RFC 1554
41JIS_C6220-1969-jp5JIS_C6220-1969; iso-ir-13; katakana; x0201-7; csISO13JISC6220jp[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
42JIS_C6220-1969-ro4iso-ir-14; jp; ISO646-JP; csISO14JISC6220ro[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
43PT3iso-ir-16; ISO646-PT; csISO16Portuguese[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
44greek7-old2iso-ir-18; csISO18Greek7Old[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
45latin-greek2iso-ir-19; csISO19LatinGreek[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
46NF_Z_62-010_(1973)3iso-ir-25; ISO646-FR1; csISO25French[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
47Latin-greek-12iso-ir-27; csISO27LatinGreek1[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
48ISO_54272iso-ir-37; csISO5427Cyrillic[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
49JIS_C6226-19782iso-ir-42; csISO42JISC62261978[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
50BS_viewdata2iso-ir-47; csISO47BSViewdata[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
51INIS2iso-ir-49; csISO49INIS[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
52INIS-82iso-ir-50; csISO50INIS8[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
53INIS-cyrillic2iso-ir-51; csISO51INISCyrillic[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
54ISO_5427:19813iso-ir-54; ISO5427Cyrillic1981; csISO54271981[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
55ISO_5428:19802iso-ir-55; csISO5428Greek[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
56GB_1988-804iso-ir-57; cn; ISO646-CN; csISO57GB1988[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
57GB_2312-803iso-ir-58; chinese; csISO58GB231280[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
58NS_4551-24ISO646-NO2; iso-ir-61; no2; csISO61Norwegian2[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
59videotex-suppl2iso-ir-70; csISO70VideotexSupp1[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
60PT23iso-ir-84; ISO646-PT2; csISO84Portuguese2[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
61ES23iso-ir-85; ISO646-ES2; csISO85Spanish2[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
62MSZ_7795.34iso-ir-86; ISO646-HU; hu; csISO86Hungarian[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
63JIS_C6226-19834iso-ir-87; x0208; JIS_X0208-1983; csISO87JISX0208[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
64greek72iso-ir-88; csISO88Greek7[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
65ASMO_4494ISO_9036; arabic7; iso-ir-89; csISO89ASMO449[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
66iso-ir-901csISO90[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
67JIS_C6229-1984-a3iso-ir-91; jp-ocr-a; csISO91JISC62291984a[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
68JIS_C6229-1984-b4iso-ir-92; ISO646-JP-OCR-B; jp-ocr-b; csISO92JISC62991984b[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
69JIS_C6229-1984-b-add3iso-ir-93; jp-ocr-b-add; csISO93JIS62291984badd[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
70JIS_C6229-1984-hand3iso-ir-94; jp-ocr-hand; csISO94JIS62291984hand[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
71JIS_C6229-1984-hand-add3iso-ir-95; jp-ocr-hand-add; csISO95JIS62291984handadd[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
72JIS_C6229-1984-kana2iso-ir-96; csISO96JISC62291984kana[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
73ISO_2033-19833iso-ir-98; e13b; csISO2033[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
74ANSI_X3.110-19834iso-ir-99; CSA_T500-1983; NAPLPS; csISO99NAPLPS[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
75T.61-7bit2iso-ir-102; csISO102T617bit[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
76T.61-8bit3T.61; iso-ir-103; csISO103T618bit[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
77ECMA-cyrillic3iso-ir-111; KOI8-E; csISO111ECMACyrillic[ISO registry]
78CSA_Z243.4-1985-16iso-ir-121; ISO646-CA; csa7-1; csa71; ca; csISO121Canadian1[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
79CSA_Z243.4-1985-25iso-ir-122; ISO646-CA2; csa7-2; csa72; csISO122Canadian2[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
80CSA_Z243.4-1985-gr2iso-ir-123; csISO123CSAZ24341985gr[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
81ISO_8859-6-EISO-8859-6-E2csISO88596E; ISO-8859-6-E[RFC 1556]RFC 1556; IANA
82ISO_8859-6-IISO-8859-6-I2csISO88596I; ISO-8859-6-I[RFC 1556]RFC 1556; IANA
83T.101-G22iso-ir-128; csISO128T101G2[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
84ISO_8859-8-EISO-8859-8-E2csISO88598E; ISO-8859-8-E[RFC 1556]RFC 1556
85ISO_8859-8-IISO-8859-8-I2csISO88598I; ISO-8859-8-I[RFC 1556]RFC 1556
86CSN_3691032iso-ir-139; csISO139CSN369103[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
87JUS_I.B1.0025iso-ir-141; ISO646-YU; js; yu; csISO141JUSIB1002[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
88IEC_P27-12iso-ir-143; csISO143IECP271[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
89JUS_I.B1.003-serb3iso-ir-146; serbian; csISO146Serbian[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
90JUS_I.B1.003-mac3macedonian; iso-ir-147; csISO147Macedonian[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
91greek-ccitt3iso-ir-150; csISO150; csISO150GreekCCITT[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
92NC_NC00-10:814cuba; iso-ir-151; ISO646-CU; csISO151Cuba[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
93ISO_6937-2-252iso-ir-152; csISO6937Add[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
94GOST_19768-743ST_SEV_358-88; iso-ir-153; csISO153GOST1976874[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
95ISO_8859-supp3iso-ir-154; latin1-2-5; csISO8859Supp[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
96ISO_10367-box2iso-ir-155; csISO10367Box[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
97latin-lap3lap; iso-ir-158; csISO158Lap[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
98JIS_X0212-19903x0212; iso-ir-159; csISO159JISX02121990[ISO-IR: International Register of Escape Sequences] Note: The current registration authority is IPSJ/ITSCJ, Japan.RFC 1345
99DS_20894DS2089; ISO646-DK; dk; csISO646DanishDanish Standard, DS 2089, February 1974RFC 1345
100us-dk1csUSDKRFC 1345
101dk-us1csDKUSRFC 1345
102KSC56362ISO646-KR; csKSC5636RFC 1345
103UNICODE-1-1-UTF-71csUnicode11UTF7[RFC 1642]RFC 1642
104ISO-2022-CN1csISO2022CN[RFC 1922]RFC 1922
105ISO-2022-CN-EXT1csISO2022CNEXT[RFC 1922]RFC 1922
106UTF-81csUTF8[RFC 3629]RFC 3629
109ISO-8859-131csISO885913ISO See [https://www.iana.org/assignments/charset-reg/ISO-8859-13]; [Vladas_Tumasonis]
110ISO-8859-147iso-ir-199; ISO_8859-14:1998; ISO_8859-14; latin8; iso-celtic; l8; csISO885914ISO See [https://www.iana.org/assignments/charset-reg/ISO-8859-14]; [Keld_Simonsen_2]
111ISO-8859-153ISO_8859-15; Latin-9; csISO885915ISO Please see: [https://www.iana.org/assignments/charset-reg/ISO-8859-15]
112ISO-8859-166iso-ir-226; ISO_8859-16:2001; ISO_8859-16; latin10; l10; csISO885916ISO
113GBK4CP936; MS936; windows-936; csGBKChinese IT Standardization Technical Committee Please see: [https://www.iana.org/assignments/charset-reg/GBK]
114GB180301csGB18030Chinese IT Standardization Technical Committee Please see: [https://www.iana.org/assignments/charset-reg/GB18030]
115OSD_EBCDIC_DF04_151csOSDEBCDICDF0415Fujitsu-Siemens standard mainframe EBCDIC encoding Please see: [https://www.iana.org/assignments/charset-reg/OSD-EBCDIC-DF04-15]
116OSD_EBCDIC_DF03_IRV1csOSDEBCDICDF03IRVFujitsu-Siemens standard mainframe EBCDIC encoding Please see: [https://www.iana.org/assignments/charset-reg/OSD-EBCDIC-DF03-IRV]
117OSD_EBCDIC_DF04_11csOSDEBCDICDF041Fujitsu-Siemens standard mainframe EBCDIC encoding Please see: [https://www.iana.org/assignments/charset-reg/OSD-EBCDIC-DF04-1]
118ISO-11548-13ISO_11548-1; ISO_TR_11548-1; csISO115481See [https://www.iana.org/assignments/charset-reg/ISO-11548-1]; [Samuel_Thibault]
119KZ-10483STRK1048-2002; RK1048; csKZ1048See [https://www.iana.org/assignments/charset-reg/KZ-1048]; [Sairan_M_Kikkarin]; [Alexei_Veremeev]
1000ISO-10646-UCS-21csUnicodethe 2-octet Basic Multilingual Plane, aka Unicode this needs to specify network byte order: the standard does not specify (it is a 16-bit integer space)
1001ISO-10646-UCS-41csUCS4the full code space. (same comment about byte order, these are 31-bit numbers.
1002ISO-10646-UCS-Basic1csUnicodeASCIIASCII subset of Unicode. Basic Latin = collection 1 See ISO 10646, Appendix A
1003ISO-10646-Unicode-Latin12csUnicodeLatin1; ISO-10646ISO Latin-1 subset of Unicode. Basic Latin and Latin-1 Supplement = collections 1 and 2. See ISO 10646, Appendix A. See [RFC 1815].
1004ISO-10646-J-11csUnicodeJapaneseISO 10646 Japanese, see [RFC 1815].
1005ISO-Unicode-IBM-12611csUnicodeIBM1261IBM Latin-2, -3, -5, Extended Presentation Set, GCSGID: 1261
1006ISO-Unicode-IBM-12681csUnicodeIBM1268IBM Latin-4 Extended Presentation Set, GCSGID: 1268
1007ISO-Unicode-IBM-12761csUnicodeIBM1276IBM Cyrillic Greek Extended Presentation Set, GCSGID: 1276
1008ISO-Unicode-IBM-12641csUnicodeIBM1264IBM Arabic Presentation Set, GCSGID: 1264
1009ISO-Unicode-IBM-12651csUnicodeIBM1265IBM Hebrew Presentation Set, GCSGID: 1265
1010UNICODE-1-11csUnicode11[RFC 1641]RFC 1641
1011SCSU1csSCSUSCSU See [https://www.iana.org/assignments/charset-reg/SCSU]; [Markus_Scherer]
1012UTF-71csUTF7[RFC 2152]RFC 2152
1013UTF-16BE1csUTF16BE[RFC 2781]RFC 2781
1014UTF-16LE1csUTF16LE[RFC 2781]RFC 2781
1015UTF-161csUTF16[RFC 2781]RFC 2781
1016CESU-82csCESU8; csCESU-8[http://www.unicode.org/unicode/reports/tr26]
1017UTF-321csUTF32[http://www.unicode.org/unicode/reports/tr19/]
1018UTF-32BE1csUTF32BE[http://www.unicode.org/unicode/reports/tr19/]
1019UTF-32LE1csUTF32LE[http://www.unicode.org/unicode/reports/tr19/]
1020BOCU-12csBOCU1; csBOCU-1[http://www.unicode.org/notes/tn6/]
1021UTF-7-IMAP1csUTF7IMAPNote: This charset is used to encode Unicode in IMAP mailbox names; see [Section 5.1.3 of RFC 3501]. It should never be used outside this context. A name has been assigned so that charset processing implementations can refer to it in a consistent way.
2000ISO-8859-1-Windows-3.0-Latin-11csWindows30Latin1Extended ISO 8859-1 Latin-1 for Windows 3.0. PCL Symbol Set id: 9U
2001ISO-8859-1-Windows-3.1-Latin-11csWindows31Latin1Extended ISO 8859-1 Latin-1 for Windows 3.1. PCL Symbol Set id: 19U
2002ISO-8859-2-Windows-Latin-21csWindows31Latin2Extended ISO 8859-2. Latin-2 for Windows 3.1. PCL Symbol Set id: 9E
2003ISO-8859-9-Windows-Latin-51csWindows31Latin5Extended ISO 8859-9. Latin-5 for Windows 3.1 PCL Symbol Set id: 5T
2004hp-roman83roman8; r8; csHPRoman8LaserJet IIP Printer User's Manual, HP part no 33471-90901, Hewlet-Packard, June 1989.RFC 1345
2005Adobe-Standard-Encoding1csAdobeStandardEncodingPostScript Language Reference Manual PCL Symbol Set id: 10J
2006Ventura-US1csVenturaUSVentura US. ASCII plus characters typically used in publishing, like pilcrow, copyright, registered, trade mark, section, dagger, and double dagger in the range A0 (hex) to FF (hex). PCL Symbol Set id: 14J
2007Ventura-International1csVenturaInternationalVentura International. ASCII plus coded characters similar to Roman8. PCL Symbol Set id: 13J
2008DEC-MCS2dec; csDECMCSVAX/VMS User's Manual, Order Number: AI-Y517A-TE, April 1986.RFC 1345
2009IBM8503cp850; 850; csPC850MultilingualIBM NLS RM Vol2 SE09-8002-01, March 1990RFC 1345
2010IBM8523cp852; 852; csPCp852IBM NLS RM Vol2 SE09-8002-01, March 1990RFC 1345
2011IBM4373cp437; 437; csPC8CodePage437IBM NLS RM Vol2 SE09-8002-01, March 1990RFC 1345
2012PC8-Danish-Norwegian1csPC8DanishNorwegianPC Danish Norwegian 8-bit PC set for Danish Norwegian PCL Symbol Set id: 11U
2013IBM8623cp862; 862; csPC862LatinHebrewIBM NLS RM Vol2 SE09-8002-01, March 1990RFC 1345
2014PC8-Turkish1csPC8TurkishPC Latin Turkish. PCL Symbol Set id: 9T
2015IBM-Symbols1csIBMSymbolsPresentation Set, CPGID: 259
2016IBM-Thai1csIBMThaiPresentation Set, CPGID: 838
2017HP-Legal1csHPLegalPCL 5 Comparison Guide, Hewlett-Packard, HP part number 5961-0510, October 1992 PCL Symbol Set id: 1U
2018HP-Pi-font1csHPPiFontPCL 5 Comparison Guide, Hewlett-Packard, HP part number 5961-0510, October 1992 PCL Symbol Set id: 15U
2019HP-Math81csHPMath8PCL 5 Comparison Guide, Hewlett-Packard, HP part number 5961-0510, October 1992 PCL Symbol Set id: 8M
2020Adobe-Symbol-Encoding1csHPPSMathPostScript Language Reference Manual PCL Symbol Set id: 5M
2021HP-DeskTop1csHPDesktopPCL 5 Comparison Guide, Hewlett-Packard, HP part number 5961-0510, October 1992 PCL Symbol Set id: 7J
2022Ventura-Math1csVenturaMathPCL 5 Comparison Guide, Hewlett-Packard, HP part number 5961-0510, October 1992 PCL Symbol Set id: 6M
2023Microsoft-Publishing1csMicrosoftPublishingPCL 5 Comparison Guide, Hewlett-Packard, HP part number 5961-0510, October 1992 PCL Symbol Set id: 6J
2024Windows-31J1csWindows31JWindows Japanese. A further extension of Shift_JIS to include NEC special characters (Row 13), NEC selection of IBM extensions (Rows 89 to 92), and IBM extensions (Rows 115 to 119). The CCS's are JIS X0201:1997, JIS X0208:1997, and these extensions. This charset can be used for the top-level media type "text", but it is of limited or specialized use (see [RFC 2278]). PCL Symbol Set id: 19K
2025GB2312GB23121csGB2312Chinese for People's Republic of China (PRC) mixed one byte, two byte set: 20-7E = one byte ASCII A1-FE = two byte PRC Kanji See GB 2312-80 PCL Symbol Set Id: 18C
2026Big5Big51csBig5Chinese for Taiwan Multi-byte set. PCL Symbol Set Id: 18T
2027macintosh2mac; csMacintoshThe Unicode Standard ver1.0, ISBN 0-201-56788-1, Oct 1991RFC 1345
2028IBM0376cp037; ebcdic-cp-us; ebcdic-cp-ca; ebcdic-cp-wt; ebcdic-cp-nl; csIBM037IBM NLS RM Vol2 SE09-8002-01, March 1990RFC 1345
2029IBM0383EBCDIC-INT; cp038; csIBM038IBM 3174 Character Set Ref, GA27-3831-02, March 1990RFC 1345
2030IBM2732CP273; csIBM273IBM NLS RM Vol2 SE09-8002-01, March 1990RFC 1345
2031IBM2743EBCDIC-BE; CP274; csIBM274IBM 3174 Character Set Ref, GA27-3831-02, March 1990RFC 1345
2032IBM2753EBCDIC-BR; cp275; csIBM275IBM NLS RM Vol2 SE09-8002-01, March 1990RFC 1345
2033IBM2773EBCDIC-CP-DK; EBCDIC-CP-NO; csIBM277IBM NLS RM Vol2 SE09-8002-01, March 1990RFC 1345
2034IBM2784CP278; ebcdic-cp-fi; ebcdic-cp-se; csIBM278IBM NLS RM Vol2 SE09-8002-01, March 1990RFC 1345
2035IBM2803CP280; ebcdic-cp-it; csIBM280IBM NLS RM Vol2 SE09-8002-01, March 1990RFC 1345
2036IBM2813EBCDIC-JP-E; cp281; csIBM281IBM 3174 Character Set Ref, GA27-3831-02, March 1990RFC 1345
2037IBM2843CP284; ebcdic-cp-es; csIBM284IBM NLS RM Vol2 SE09-8002-01, March 1990RFC 1345
2038IBM2853CP285; ebcdic-cp-gb; csIBM285IBM NLS RM Vol2 SE09-8002-01, March 1990RFC 1345
2039IBM2903cp290; EBCDIC-JP-kana; csIBM290IBM 3174 Character Set Ref, GA27-3831-02, March 1990RFC 1345
2040IBM2973cp297; ebcdic-cp-fr; csIBM297IBM NLS RM Vol2 SE09-8002-01, March 1990RFC 1345
2041IBM4203cp420; ebcdic-cp-ar1; csIBM420IBM NLS RM Vol2 SE09-8002-01, March 1990, IBM NLS RM p 11-11RFC 1345
2042IBM4233cp423; ebcdic-cp-gr; csIBM423IBM NLS RM Vol2 SE09-8002-01, March 1990RFC 1345
2043IBM4243cp424; ebcdic-cp-he; csIBM424IBM NLS RM Vol2 SE09-8002-01, March 1990RFC 1345
2044IBM5004CP500; ebcdic-cp-be; ebcdic-cp-ch; csIBM500IBM NLS RM Vol2 SE09-8002-01, March 1990RFC 1345
2045IBM8513cp851; 851; csIBM851IBM NLS RM Vol2 SE09-8002-01, March 1990RFC 1345
2046IBM8553cp855; 855; csIBM855IBM NLS RM Vol2 SE09-8002-01, March 1990RFC 1345
2047IBM8573cp857; 857; csIBM857IBM NLS RM Vol2 SE09-8002-01, March 1990RFC 1345
2048IBM8603cp860; 860; csIBM860IBM NLS RM Vol2 SE09-8002-01, March 1990RFC 1345
2049IBM8614cp861; 861; cp-is; csIBM861IBM NLS RM Vol2 SE09-8002-01, March 1990RFC 1345
2050IBM8633cp863; 863; csIBM863IBM Keyboard layouts and code pages, PN 07G4586 June 1991RFC 1345
2051IBM8642cp864; csIBM864IBM Keyboard layouts and code pages, PN 07G4586 June 1991RFC 1345
2052IBM8653cp865; 865; csIBM865IBM DOS 3.3 Ref (Abridged), 94X9575 (Feb 1987)RFC 1345
2053IBM8683CP868; cp-ar; csIBM868IBM NLS RM Vol2 SE09-8002-01, March 1990RFC 1345
2054IBM8694cp869; 869; cp-gr; csIBM869IBM Keyboard layouts and code pages, PN 07G4586 June 1991RFC 1345
2055IBM8704CP870; ebcdic-cp-roece; ebcdic-cp-yu; csIBM870IBM NLS RM Vol2 SE09-8002-01, March 1990RFC 1345
2056IBM8713CP871; ebcdic-cp-is; csIBM871IBM NLS RM Vol2 SE09-8002-01, March 1990RFC 1345
2057IBM8803cp880; EBCDIC-Cyrillic; csIBM880IBM NLS RM Vol2 SE09-8002-01, March 1990RFC 1345
2058IBM8912cp891; csIBM891IBM NLS RM Vol2 SE09-8002-01, March 1990RFC 1345
2059IBM9032cp903; csIBM903IBM NLS RM Vol2 SE09-8002-01, March 1990RFC 1345
2060IBM9043cp904; 904; csIBBM904IBM NLS RM Vol2 SE09-8002-01, March 1990RFC 1345
2061IBM9053CP905; ebcdic-cp-tr; csIBM905IBM 3174 Character Set Ref, GA27-3831-02, March 1990RFC 1345
2062IBM9183CP918; ebcdic-cp-ar2; csIBM918IBM NLS RM Vol2 SE09-8002-01, March 1990RFC 1345
2063IBM10262CP1026; csIBM1026IBM NLS RM Vol2 SE09-8002-01, March 1990RFC 1345
2064EBCDIC-AT-DE1csIBMEBCDICATDEIBM 3270 Char Set Ref Ch 10, GA27-2837-9, April 1987RFC 1345
2065EBCDIC-AT-DE-A1csEBCDICATDEAIBM 3270 Char Set Ref Ch 10, GA27-2837-9, April 1987RFC 1345
2066EBCDIC-CA-FR1csEBCDICCAFRIBM 3270 Char Set Ref Ch 10, GA27-2837-9, April 1987RFC 1345
2067EBCDIC-DK-NO1csEBCDICDKNOIBM 3270 Char Set Ref Ch 10, GA27-2837-9, April 1987RFC 1345
2068EBCDIC-DK-NO-A1csEBCDICDKNOAIBM 3270 Char Set Ref Ch 10, GA27-2837-9, April 1987RFC 1345
2069EBCDIC-FI-SE1csEBCDICFISEIBM 3270 Char Set Ref Ch 10, GA27-2837-9, April 1987RFC 1345
2070EBCDIC-FI-SE-A1csEBCDICFISEAIBM 3270 Char Set Ref Ch 10, GA27-2837-9, April 1987RFC 1345
2071EBCDIC-FR1csEBCDICFRIBM 3270 Char Set Ref Ch 10, GA27-2837-9, April 1987RFC 1345
2072EBCDIC-IT1csEBCDICITIBM 3270 Char Set Ref Ch 10, GA27-2837-9, April 1987RFC 1345
2073EBCDIC-PT1csEBCDICPTIBM 3270 Char Set Ref Ch 10, GA27-2837-9, April 1987RFC 1345
2074EBCDIC-ES1csEBCDICESIBM 3270 Char Set Ref Ch 10, GA27-2837-9, April 1987RFC 1345
2075EBCDIC-ES-A1csEBCDICESAIBM 3270 Char Set Ref Ch 10, GA27-2837-9, April 1987RFC 1345
2076EBCDIC-ES-S1csEBCDICESSIBM 3270 Char Set Ref Ch 10, GA27-2837-9, April 1987RFC 1345
2077EBCDIC-UK1csEBCDICUKIBM 3270 Char Set Ref Ch 10, GA27-2837-9, April 1987RFC 1345
2078EBCDIC-US1csEBCDICUSIBM 3270 Char Set Ref Ch 10, GA27-2837-9, April 1987RFC 1345
2079UNKNOWN-8BIT1csUnknown8BiTRFC 1428
2080MNEMONIC1csMnemonic[RFC 1345], also known as "mnemonic+ascii+38"RFC 1345
2081MNEM1csMnem[RFC 1345], also known as "mnemonic+ascii+8200"RFC 1345
2082VISCII1csVISCII[RFC 1456]RFC 1456
2083VIQR1csVIQR[RFC 1456]RFC 1456
2084KOI8-RKOI8-R1csKOI8R[RFC 1489], based on GOST-19768-74, ISO-6937/8, INIS-Cyrillic, ISO-5427.RFC 1489
2085HZ-GB-23120[RFC 1842], [RFC 1843]; [RFC 1843]; [RFC 1842]
2086IBM8663cp866; 866; csIBM866IBM NLDG Volume 2 (SE09-8002-03) August 1994
2087IBM7752cp775; csPC775BalticHP PCL 5 Comparison Guide (P/N 5021-0329) pp B-13, 1996
2088KOI8-U1csKOI8U[RFC 2319]RFC 2319
2089IBM008584CCSID00858; CP00858; PC-Multilingual-850+euro; csIBM00858IBM See [https://www.iana.org/assignments/charset-reg/IBM00858]; [Tamer_Mahdi]
2090IBM009244CCSID00924; CP00924; ebcdic-Latin9--euro; csIBM00924IBM See [https://www.iana.org/assignments/charset-reg/IBM00924]; [Tamer_Mahdi]
2091IBM011404CCSID01140; CP01140; ebcdic-us-37+euro; csIBM01140IBM See [https://www.iana.org/assignments/charset-reg/IBM01140]; [Tamer_Mahdi]
2092IBM011414CCSID01141; CP01141; ebcdic-de-273+euro; csIBM01141IBM See [https://www.iana.org/assignments/charset-reg/IBM01141]; [Tamer_Mahdi]
2093IBM011425CCSID01142; CP01142; ebcdic-dk-277+euro; ebcdic-no-277+euro; csIBM01142IBM See [https://www.iana.org/assignments/charset-reg/IBM01142]; [Tamer_Mahdi]
2094IBM011435CCSID01143; CP01143; ebcdic-fi-278+euro; ebcdic-se-278+euro; csIBM01143IBM See [https://www.iana.org/assignments/charset-reg/IBM01143]; [Tamer_Mahdi]
2095IBM011444CCSID01144; CP01144; ebcdic-it-280+euro; csIBM01144IBM See [https://www.iana.org/assignments/charset-reg/IBM01144]; [Tamer_Mahdi]
2096IBM011454CCSID01145; CP01145; ebcdic-es-284+euro; csIBM01145IBM See [https://www.iana.org/assignments/charset-reg/IBM01145]; [Tamer_Mahdi]
2097IBM011464CCSID01146; CP01146; ebcdic-gb-285+euro; csIBM01146IBM See [https://www.iana.org/assignments/charset-reg/IBM01146]; [Tamer_Mahdi]
2098IBM011474CCSID01147; CP01147; ebcdic-fr-297+euro; csIBM01147IBM See [https://www.iana.org/assignments/charset-reg/IBM01147]; [Tamer_Mahdi]
2099IBM011484CCSID01148; CP01148; ebcdic-international-500+euro; csIBM01148IBM See [https://www.iana.org/assignments/charset-reg/IBM01148]; [Tamer_Mahdi]
2100IBM011494CCSID01149; CP01149; ebcdic-is-871+euro; csIBM01149IBM See [https://www.iana.org/assignments/charset-reg/IBM01149]; [Tamer_Mahdi]
2101Big5-HKSCS1csBig5HKSCSSee [https://www.iana.org/assignments/charset-reg/Big5-HKSCS]
2102IBM10472IBM-1047; csIBM1047IBM1047 (EBCDIC Latin 1/Open Systems) [http://www-1.ibm.com/servers/eserver/iseries/software/globalization/pdf/cp01047z.pdf]
2103PTCP1544csPTCP154; PT154; CP154; Cyrillic-AsianSee [https://www.iana.org/assignments/charset-reg/PTCP154]
2104Amiga-12515Ami1251; Amiga1251; Ami-1251; csAmiga1251; (Aliases are provided for historical reasons and should not be used) [Malyshev]See [http://www.amiga.ultranet.ru/Amiga-1251.html]
2105KOI7-switched1csKOI7switchedSee [https://www.iana.org/assignments/charset-reg/KOI7-switched]
2106BRF1csBRFSee [https://www.iana.org/assignments/charset-reg/BRF]; [Samuel_Thibault]
2107TSCII1csTSCIISee [https://www.iana.org/assignments/charset-reg/TSCII]; [Kuppuswamy_Kalyanasu]
2108CP519321csCP51932See [https://www.iana.org/assignments/charset-reg/CP51932]; [Yui_Naruse]
2109windows-8741cswindows874See [https://www.iana.org/assignments/charset-reg/windows-874]; [Shawn_Steele]
2250windows-12501cswindows1250Microsoft [https://www.iana.org/assignments/charset-reg/windows-1250]; [Katya_Lazhintseva]
2251windows-12511cswindows1251Microsoft [https://www.iana.org/assignments/charset-reg/windows-1251]; [Katya_Lazhintseva]
2252windows-12521cswindows1252Microsoft [https://www.iana.org/assignments/charset-reg/windows-1252]; [Chris_Wendt]
2253windows-12531cswindows1253Microsoft [https://www.iana.org/assignments/charset-reg/windows-1253]; [Katya_Lazhintseva]
2254windows-12541cswindows1254Microsoft [https://www.iana.org/assignments/charset-reg/windows-1254]; [Katya_Lazhintseva]
2255windows-12551cswindows1255Microsoft [https://www.iana.org/assignments/charset-reg/windows-1255]; [Katya_Lazhintseva]
2256windows-12561cswindows1256Microsoft [https://www.iana.org/assignments/charset-reg/windows-1256]; [Katya_Lazhintseva]
2257windows-12571cswindows1257Microsoft [https://www.iana.org/assignments/charset-reg/windows-1257]; [Katya_Lazhintseva]
2258windows-12581cswindows1258Microsoft [https://www.iana.org/assignments/charset-reg/windows-1258]; [Katya_Lazhintseva]
2259TIS-6202csTIS620; ISO-8859-11Thai Industrial Standards Institute (TISI) [Trin_Tantsetthi]
2260CP502201csCP50220See [https://www.iana.org/assignments/charset-reg/CP50220]; [Yui_Naruse]