# HTTP status codes (IANA registry)

| Code | Reason phrase | Class | Temporary registration | Defining RFC | References |
| ---: | --- | --- | --- | ---: | --- |
| 100 | Continue | Informational | false | 9110 | RFC 9110, Section 15.2.1 |
| 101 | Switching Protocols | Informational | false | 9110 | RFC 9110, Section 15.2.2 |
| 102 | Processing | Informational | false | 2518 | RFC 2518 |
| 103 | Early Hints | Informational | false | 8297 | RFC 8297 |
| 104 | Upload Resumption Supported (TEMPORARY - registered 2024-11-13, extension registered 2025-09-15, expires 2026-11-13) | Informational | true |  | draft-ietf-httpbis-resumable-upload-05 |
| 200 | OK | Successful | false | 9110 | RFC 9110, Section 15.3.1 |
| 201 | Created | Successful | false | 9110 | RFC 9110, Section 15.3.2 |
| 202 | Accepted | Successful | false | 9110 | RFC 9110, Section 15.3.3 |
| 203 | Non-Authoritative Information | Successful | false | 9110 | RFC 9110, Section 15.3.4 |
| 204 | No Content | Successful | false | 9110 | RFC 9110, Section 15.3.5 |
| 205 | Reset Content | Successful | false | 9110 | RFC 9110, Section 15.3.6 |
| 206 | Partial Content | Successful | false | 9110 | RFC 9110, Section 15.3.7 |
| 207 | Multi-Status | Successful | false | 4918 | RFC 4918 |
| 208 | Already Reported | Successful | false | 5842 | RFC 5842 |
| 226 | IM Used | Successful | false | 3229 | RFC 3229 |
| 300 | Multiple Choices | Redirection | false | 9110 | RFC 9110, Section 15.4.1 |
| 301 | Moved Permanently | Redirection | false | 9110 | RFC 9110, Section 15.4.2 |
| 302 | Found | Redirection | false | 9110 | RFC 9110, Section 15.4.3 |
| 303 | See Other | Redirection | false | 9110 | RFC 9110, Section 15.4.4 |
| 304 | Not Modified | Redirection | false | 9110 | RFC 9110, Section 15.4.5 |
| 305 | Use Proxy | Redirection | false | 9110 | RFC 9110, Section 15.4.6 |
| 306 | (Unused) | Redirection | false | 9110 | RFC 9110, Section 15.4.7 |
| 307 | Temporary Redirect | Redirection | true | 9110 | RFC 9110, Section 15.4.8 |
| 308 | Permanent Redirect | Redirection | false | 9110 | RFC 9110, Section 15.4.9 |
| 400 | Bad Request | Client error | false | 9110 | RFC 9110, Section 15.5.1 |
| 401 | Unauthorized | Client error | false | 9110 | RFC 9110, Section 15.5.2 |
| 402 | Payment Required | Client error | false | 9110 | RFC 9110, Section 15.5.3 |
| 403 | Forbidden | Client error | false | 9110 | RFC 9110, Section 15.5.4 |
| 404 | Not Found | Client error | false | 9110 | RFC 9110, Section 15.5.5 |
| 405 | Method Not Allowed | Client error | false | 9110 | RFC 9110, Section 15.5.6 |
| 406 | Not Acceptable | Client error | false | 9110 | RFC 9110, Section 15.5.7 |
| 407 | Proxy Authentication Required | Client error | false | 9110 | RFC 9110, Section 15.5.8 |
| 408 | Request Timeout | Client error | false | 9110 | RFC 9110, Section 15.5.9 |
| 409 | Conflict | Client error | false | 9110 | RFC 9110, Section 15.5.10 |
| 410 | Gone | Client error | false | 9110 | RFC 9110, Section 15.5.11 |
| 411 | Length Required | Client error | false | 9110 | RFC 9110, Section 15.5.12 |
| 412 | Precondition Failed | Client error | false | 9110 | RFC 9110, Section 15.5.13 |
| 413 | Content Too Large | Client error | false | 9110 | RFC 9110, Section 15.5.14 |
| 414 | URI Too Long | Client error | false | 9110 | RFC 9110, Section 15.5.15 |
| 415 | Unsupported Media Type | Client error | false | 9110 | RFC 9110, Section 15.5.16 |
| 416 | Range Not Satisfiable | Client error | false | 9110 | RFC 9110, Section 15.5.17 |
| 417 | Expectation Failed | Client error | false | 9110 | RFC 9110, Section 15.5.18 |
| 418 | (Unused) | Client error | false | 9110 | RFC 9110, Section 15.5.19 |
| 421 | Misdirected Request | Client error | false | 9110 | RFC 9110, Section 15.5.20 |
| 422 | Unprocessable Content | Client error | false | 9110 | RFC 9110, Section 15.5.21 |
| 423 | Locked | Client error | false | 4918 | RFC 4918 |
| 424 | Failed Dependency | Client error | false | 4918 | RFC 4918 |
| 425 | Too Early | Client error | false | 8470 | RFC 8470 |
| 426 | Upgrade Required | Client error | false | 9110 | RFC 9110, Section 15.5.22 |
| 428 | Precondition Required | Client error | false | 6585 | RFC 6585 |
| 429 | Too Many Requests | Client error | false | 6585 | RFC 6585 |
| 431 | Request Header Fields Too Large | Client error | false | 6585 | RFC 6585 |
| 451 | Unavailable For Legal Reasons | Client error | false | 7725 | RFC 7725 |
| 500 | Internal Server Error | Server error | false | 9110 | RFC 9110, Section 15.6.1 |
| 501 | Not Implemented | Server error | false | 9110 | RFC 9110, Section 15.6.2 |
| 502 | Bad Gateway | Server error | false | 9110 | RFC 9110, Section 15.6.3 |
| 503 | Service Unavailable | Server error | false | 9110 | RFC 9110, Section 15.6.4 |
| 504 | Gateway Timeout | Server error | false | 9110 | RFC 9110, Section 15.6.5 |
| 505 | HTTP Version Not Supported | Server error | false | 9110 | RFC 9110, Section 15.6.6 |
| 506 | Variant Also Negotiates | Server error | false | 2295 | RFC 2295 |
| 507 | Insufficient Storage | Server error | false | 4918 | RFC 4918 |
| 508 | Loop Detected | Server error | false | 5842 | RFC 5842 |
| 510 | Not Extended (OBSOLETED) | Server error | false | 2774 | RFC 2774 |
| 511 | Network Authentication Required | Server error | false | 6585 | RFC 6585 |

Source: https://aidb.si/d/http-status-codes — Source: Internet Assigned Numbers Authority (IANA), HTTP Status Code Registry.

