# HTTP header fields (IANA registry)

| Field name | Status | Structured type | Defining RFC | References | Comments |
| --- | --- | --- | ---: | --- | --- |
| * | permanent |  | 9110 | RFC 9110, Section 12.5.5 | (reserved) |
| A-IM | permanent |  | 3229 | RFC 3229 |  |
| ALPN | permanent |  | 7639 | RFC 7639, Section 2 |  |
| AMP-Cache-Transform | provisional |  |  |  |  |
| Accept | permanent |  | 9110 | RFC 9110, Section 12.5.1 |  |
| Accept-Additions | permanent |  | 2324 | RFC 2324 |  |
| Accept-CH | permanent | List | 8942 | RFC 8942, Section 3.1 |  |
| Accept-Charset | deprecated |  | 9110 | RFC 9110, Section 12.5.2 |  |
| Accept-Datetime | permanent |  | 7089 | RFC 7089 |  |
| Accept-Encoding | permanent |  | 9110 | RFC 9110, Section 12.5.3 |  |
| Accept-Features | permanent |  | 2295 | RFC 2295 |  |
| Accept-Language | permanent |  | 9110 | RFC 9110, Section 12.5.4 |  |
| Accept-Patch | permanent |  | 5789 | RFC 5789 |  |
| Accept-Post | permanent |  |  |  |  |
| Accept-Query | permanent | List | 10008 | RFC 10008, Section 3 |  |
| Accept-Ranges | permanent |  | 9110 | RFC 9110, Section 14.3 |  |
| Accept-Signature | permanent |  | 9421 | RFC 9421, Section 5.1 |  |
| Access-Control | obsoleted |  |  |  |  |
| Access-Control-Allow-Credentials | permanent |  |  |  |  |
| Access-Control-Allow-Headers | permanent |  |  |  |  |
| Access-Control-Allow-Methods | permanent |  |  |  |  |
| Access-Control-Allow-Origin | permanent |  |  |  |  |
| Access-Control-Expose-Headers | permanent |  |  |  |  |
| Access-Control-Max-Age | permanent |  |  |  |  |
| Access-Control-Request-Headers | permanent |  |  |  |  |
| Access-Control-Request-Method | permanent |  |  |  |  |
| Activate-Storage-Access | provisional | Item |  | https://privacycg.github.io/storage-access-headers |  |
| Age | permanent |  | 9111 | RFC 9111, Section 5.1 |  |
| Allow | permanent |  | 9110 | RFC 9110, Section 10.2.1 |  |
| Alt-Svc | permanent |  | 7838 | RFC 7838 |  |
| Alt-Used | permanent |  | 7838 | RFC 7838 |  |
| Alternates | permanent |  | 2295 | RFC 2295 |  |
| Apply-To-Redirect-Ref | permanent |  | 4437 | RFC 4437 |  |
| Authentication-Control | permanent |  | 8053 | RFC 8053, Section 4 |  |
| Authentication-Info | permanent |  | 9110 | RFC 9110, Section 11.6.3 |  |
| Authorization | permanent |  | 9110 | RFC 9110, Section 11.6.2 |  |
| Available-Dictionary | permanent | Item | 9842 | RFC 9842, Section 2.2 |  |
| C-Ext | obsoleted |  | 2774 | RFC 2774 | [Status change of HTTP experiments to Historic] |
| C-Man | obsoleted |  | 2774 | RFC 2774 | [Status change of HTTP experiments to Historic] |
| C-Opt | obsoleted |  | 2774 | RFC 2774 | [Status change of HTTP experiments to Historic] |
| C-PEP | obsoleted |  |  |  | [Status change of HTTP experiments to Historic] |
| C-PEP-Info | deprecated |  |  |  | [Status change of HTTP experiments to Historic] |
| CDN-Cache-Control | permanent | Dictionary | 9213 | RFC 9213 | Cache directives targeted at content delivery networks |
| CDN-Loop | permanent |  | 8586 | RFC 8586 |  |
| CMCD-Object | provisional |  |  | CTA |  |
| CMCD-Request | provisional |  |  | CTA |  |
| CMCD-Session | provisional |  |  | CTA |  |
| CMCD-Status | provisional |  |  | CTA |  |
| CMSD-Dynamic | provisional |  |  | CTA |  |
| CMSD-Static | provisional |  |  | CTA |  |
| CTA-Common-Access-Token | provisional |  |  | CTA |  |
| Cache-Control | permanent |  | 9111 | RFC 9111, Section 5.2 |  |
| Cache-Group-Invalidation | permanent | List | 9875 | RFC 9875 |  |
| Cache-Groups | permanent | List | 9875 | RFC 9875 |  |
| Cache-Status | permanent | List | 9211 | RFC 9211 |  |
| Cal-Managed-ID | permanent |  | 8607 | RFC 8607, Section 5.1 |  |
| CalDAV-Timezones | permanent |  | 7809 | RFC 7809, Section 7.1 |  |
| Capsule-Protocol | permanent | Item | 9297 | RFC 9297 |  |
| Cert-Not-After | permanent |  | 8739 | RFC 8739, Section 3.3 |  |
| Cert-Not-Before | permanent |  | 8739 | RFC 8739, Section 3.3 |  |
| Clear-Site-Data | permanent |  |  |  |  |
| Client-Cert | permanent | Item | 9440 | RFC 9440, Section 2 |  |
| Client-Cert-Chain | permanent | List | 9440 | RFC 9440, Section 2 |  |
| Close | permanent |  | 9112 | RFC 9112, Section 9.6 | (reserved) |
| Concealed-Auth-Export | permanent | Item | 9729 | RFC 9729 |  |
| Configuration-Context | provisional |  |  |  |  |
| Connect-UDP-Bind | permanent | Item |  |  |  |
| Connection | permanent |  | 9110 | RFC 9110, Section 7.6.1 |  |
| Content-Base | obsoleted |  | 2068 | RFC 2068 | Obsoleted by [RFC 2616: Hypertext Transfer Protocol -- HTTP/1.1] |
| Content-Digest | permanent | Dictionary | 9530 | RFC 9530, Section 2 |  |
| Content-Disposition | permanent |  | 6266 | RFC 6266 |  |
| Content-Encoding | permanent |  | 9110 | RFC 9110, Section 8.4 |  |
| Content-ID | deprecated |  |  |  |  |
| Content-Language | permanent |  | 9110 | RFC 9110, Section 8.5 |  |
| Content-Length | permanent |  | 9110 | RFC 9110, Section 8.6 |  |
| Content-Location | permanent |  | 9110 | RFC 9110, Section 8.7 |  |
| Content-MD5 | obsoleted |  | 2616 | RFC 2616, Section 14.15 | Obsoleted by [RFC 7231, Appendix B: Hypertext Transfer Protocol (HTTP/1.1): Semantics and Content] |
| Content-Range | permanent |  | 9110 | RFC 9110, Section 14.4 |  |
| Content-Script-Type | obsoleted |  |  | HTML 4.01 Specification |  |
| Content-Security-Policy | permanent |  |  |  |  |
| Content-Security-Policy-Report-Only | permanent |  |  |  |  |
| Content-Style-Type | obsoleted |  |  | HTML 4.01 Specification |  |
| Content-Type | permanent |  | 9110 | RFC 9110, Section 8.3 |  |
| Content-Version | obsoleted |  | 2068 | RFC 2068 |  |
| Cookie | permanent |  | 6265 |  |  |
| Cookie2 | obsoleted |  | 2965 | RFC 2965 | Obsoleted by [RFC 6265: HTTP State Management Mechanism] |
| Cross-Origin-Embedder-Policy | permanent | Item |  | HTML |  |
| Cross-Origin-Embedder-Policy-Report-Only | permanent | Item |  | HTML |  |
| Cross-Origin-Opener-Policy | permanent | Item |  | HTML |  |
| Cross-Origin-Opener-Policy-Report-Only | permanent | Item |  | HTML |  |
| Cross-Origin-Resource-Policy | permanent |  |  |  |  |
| DASL | permanent |  | 5323 | RFC 5323 |  |
| DAV | permanent |  | 4918 | RFC 4918 |  |
| DPoP | permanent |  | 9449 | RFC 9449 |  |
| DPoP-Nonce | permanent |  | 9449 | RFC 9449 |  |
| Date | permanent |  | 9110 | RFC 9110, Section 6.6.1 |  |
| Default-Style | obsoleted |  |  | HTML 4.01 Specification |  |
| Delta-Base | permanent |  | 3229 | RFC 3229 |  |
| Deprecation | permanent | Item | 9745 | RFC 9745, Section 2 |  |
| Depth | permanent |  | 4918 | RFC 4918 |  |
| Derived-From | obsoleted |  | 2068 | RFC 2068 |  |
| Destination | permanent |  | 4918 | RFC 4918 |  |
| Detached-JWS | permanent |  | 9635 | RFC 9635 |  |
| Dictionary-ID | permanent | Item | 9842 | RFC 9842, Section 2.3 |  |
| Differential-ID | deprecated |  |  |  |  |
| Digest | obsoleted |  | 3230 | RFC 3230 | Obsoleted by [RFC 9530, Section 1.3: Digest Fields] |
| EDIINT-Features | provisional |  | 6017 | RFC 6017 |  |
| ETag | permanent |  | 9110 | RFC 9110, Section 8.8.3 |  |
| Early-Data | permanent |  | 8470 | RFC 8470 |  |
| Expect | permanent |  | 9110 | RFC 9110, Section 10.1.1 |  |
| Expect-CT | deprecated |  | 9163 | RFC 9163 | Obsoleted by [IESG]; [HTTPBIS] |
| Expires | permanent |  | 9111 | RFC 9111, Section 5.3 |  |
| Ext | obsoleted |  | 2774 | RFC 2774 | [Status change of HTTP experiments to Historic] |
| Forwarded | permanent |  | 7239 | RFC 7239 |  |
| From | permanent |  | 9110 | RFC 9110, Section 10.1.2 |  |
| GetProfile | obsoleted |  |  |  |  |
| HTTP2-Settings | obsoleted |  | 7540 | RFC 7540, Section 3.2.1 | Obsolete; see [Section 11.1 of RFC 9113] |
| Hobareg | permanent |  | 7486 | RFC 7486, Section 6.1.1 |  |
| Host | permanent |  | 9110 | RFC 9110, Section 7.2 |  |
| IM | permanent |  | 3229 | RFC 3229 |  |
| If | permanent |  | 4918 | RFC 4918 |  |
| If-Match | permanent |  | 9110 | RFC 9110, Section 13.1.1 |  |
| If-Modified-Since | permanent |  | 9110 | RFC 9110, Section 13.1.3 |  |
| If-None-Match | permanent |  | 9110 | RFC 9110, Section 13.1.2 |  |
| If-Range | permanent |  | 9110 | RFC 9110, Section 13.1.5 |  |
| If-Schedule-Tag-Match | permanent |  | 6338 | RFC 6338 |  |
| If-Unmodified-Since | permanent |  | 9110 | RFC 9110, Section 13.1.4 |  |
| Include-Referred-Token-Binding-ID | permanent |  | 8473 | RFC 8473 |  |
| Incremental | permanent | Item | 10036 | RFC 10036 |  |
| Isolation | provisional |  |  | OASIS |  |
| Keep-Alive | permanent |  | 2068 | RFC 2068 |  |
| Label | permanent |  | 3253 | RFC 3253 |  |
| Last-Event-ID | permanent |  |  | HTML |  |
| Last-Modified | permanent |  | 9110 | RFC 9110, Section 8.8.2 |  |
| Link | permanent |  | 8288 | RFC 8288 |  |
| Link-Template | permanent |  | 9652 | RFC 9652 |  |
| Location | permanent |  | 9110 | RFC 9110, Section 10.2.2 |  |
| Lock-Token | permanent |  | 4918 | RFC 4918 |  |
| MIME-Version | permanent |  | 9112 | RFC 9112, Appendix B.1 |  |
| Man | obsoleted |  | 2774 | RFC 2774 | [Status change of HTTP experiments to Historic] |
| Max-Forwards | permanent |  | 9110 | RFC 9110, Section 7.6.2 |  |
| Memento-Datetime | permanent |  | 7089 | RFC 7089 |  |
| Meter | permanent |  | 2227 | RFC 2227 |  |
| Method-Check | obsoleted |  |  |  |  |
| Method-Check-Expires | obsoleted |  |  |  |  |
| NEL | permanent |  |  |  |  |
| Negotiate | permanent |  | 2295 | RFC 2295 |  |
| No-Vary-Search | permanent | Dictionary |  |  |  |
| OData-EntityId | permanent |  |  | OASIS |  |
| OData-Isolation | permanent |  |  | OASIS |  |
| OData-MaxVersion | permanent |  |  | OASIS |  |
| OData-Version | permanent |  |  | OASIS |  |
| OSCORE | permanent |  | 8613 | RFC 8613, Section 11.1 |  |
| OSLC-Core-Version | permanent |  |  | OASIS Project Specification 01; OASIS |  |
| Opt | obsoleted |  | 2774 | RFC 2774 | [Status change of HTTP experiments to Historic] |
| Optional-WWW-Authenticate | permanent |  | 8053 | RFC 8053, Section 3 |  |
| Ordering-Type | permanent |  | 3648 | RFC 3648 |  |
| Origin | permanent |  | 6454 | RFC 6454 |  |
| Origin-Agent-Cluster | permanent | Item |  | HTML |  |
| Overwrite | permanent |  | 4918 | RFC 4918 |  |
| P3P | obsoleted |  |  |  |  |
| PEP | obsoleted |  |  |  |  |
| PEP-Info | obsoleted |  |  |  |  |
| PICS-Label | obsoleted |  |  |  |  |
| Permissions-Policy | provisional |  |  |  |  |
| Ping-From | permanent |  |  | HTML |  |
| Ping-To | permanent |  |  | HTML |  |
| Position | permanent |  | 3648 | RFC 3648 |  |
| Pragma | deprecated |  | 9111 | RFC 9111, Section 5.4 |  |
| Prefer | permanent |  | 7240 | RFC 7240 |  |
| Preference-Applied | permanent |  | 7240 | RFC 7240 |  |
| Priority | permanent | Dictionary | 9218 | RFC 9218 |  |
| ProfileObject | obsoleted |  |  |  |  |
| Protocol | obsoleted |  |  |  |  |
| Protocol-Info | deprecated |  |  |  |  |
| Protocol-Query | deprecated |  |  |  |  |
| Protocol-Request | obsoleted |  |  |  |  |
| Proxy-Authenticate | permanent |  | 9110 | RFC 9110, Section 11.7.1 |  |
| Proxy-Authentication-Info | permanent |  | 9110 | RFC 9110, Section 11.7.3 |  |
| Proxy-Authorization | permanent |  | 9110 | RFC 9110, Section 11.7.2 |  |
| Proxy-Features | obsoleted |  |  |  |  |
| Proxy-Instruction | obsoleted |  |  |  |  |
| Proxy-Public-Address | permanent | List |  |  |  |
| Proxy-Status | permanent | List | 9209 | RFC 9209 |  |
| Public | obsoleted |  | 2068 | RFC 2068 |  |
| Public-Key-Pins | permanent |  | 7469 | RFC 7469 |  |
| Public-Key-Pins-Report-Only | permanent |  | 7469 | RFC 7469 |  |
| Range | permanent |  | 9110 | RFC 9110, Section 14.2 |  |
| Redirect-Ref | permanent |  | 4437 | RFC 4437 |  |
| Referer | permanent |  | 9110 | RFC 9110, Section 10.1.3 |  |
| Referer-Root | obsoleted |  |  |  |  |
| Referrer-Policy | permanent |  |  |  | The header name does not share the HTTP Referer header's misspelling. |
| Refresh | permanent |  |  | HTML |  |
| Repeatability-Client-ID | provisional |  |  | OASIS |  |
| Repeatability-First-Sent | provisional |  |  | OASIS |  |
| Repeatability-Request-ID | provisional |  |  | OASIS |  |
| Repeatability-Result | provisional |  |  | OASIS |  |
| Replay-Nonce | permanent |  | 8555 | RFC 8555, Section 6.5.1 |  |
| Reporting-Endpoints | provisional |  |  |  |  |
| Repr-Digest | permanent | Dictionary | 9530 | RFC 9530, Section 3 |  |
| Retry-After | permanent |  | 9110 | RFC 9110, Section 10.2.3 |  |
| SLUG | permanent |  | 5023 | RFC 5023 |  |
| Safe | obsoleted |  | 2310 | RFC 2310 | [Status change of HTTP experiments to Historic] |
| Schedule-Reply | permanent |  | 6638 | RFC 6638 |  |
| Schedule-Tag | permanent |  | 6338 | RFC 6338 |  |
| Sec-Fetch-Dest | permanent | Item |  | https://www.w3.org/TR/fetch-metadata/#sec-fetch-dest-header |  |
| Sec-Fetch-Mode | permanent | Item |  | https://www.w3.org/TR/fetch-metadata/#sec-fetch-mode-header |  |
| Sec-Fetch-Site | permanent | Item |  | https://www.w3.org/TR/fetch-metadata/#sec-fetch-site-header |  |
| Sec-Fetch-Storage-Access | provisional | Token |  | https://privacycg.github.io/storage-access-headers |  |
| Sec-Fetch-User | permanent | Item |  | https://www.w3.org/TR/fetch-metadata/#sec-fetch-user-header |  |
| Sec-GPC | provisional |  |  |  |  |
| Sec-Purpose | permanent |  |  |  | Intended to replace the (not registered) Purpose and x-moz headers. |
| Sec-Token-Binding | permanent |  | 8473 | RFC 8473 |  |
| Sec-WebSocket-Accept | permanent |  | 6455 | RFC 6455 |  |
| Sec-WebSocket-Extensions | permanent |  | 6455 | RFC 6455 |  |
| Sec-WebSocket-Key | permanent |  | 6455 | RFC 6455 |  |
| Sec-WebSocket-Protocol | permanent |  | 6455 | RFC 6455 |  |
| Sec-WebSocket-Version | permanent |  | 6455 | RFC 6455 |  |
| Security-Scheme | obsoleted |  | 2660 | RFC 2660 | [Status change of HTTP experiments to Historic] |
| Server | permanent |  | 9110 | RFC 9110, Section 10.2.4 |  |
| Server-Timing | permanent |  |  |  |  |
| Set-Cookie | permanent |  | 6265 |  |  |
| Set-Cookie2 | obsoleted |  | 2965 | RFC 2965 | Obsoleted by [RFC 6265: HTTP State Management Mechanism] |
| Set-Txn | permanent |  | 9967 | RFC 9967, Section 3 |  |
| SetProfile | obsoleted |  |  |  |  |
| Signature | permanent | Dictionary | 9421 | RFC 9421, Section 4.2 |  |
| Signature-Input | permanent | Dictionary | 9421 | RFC 9421, Section 4.1 |  |
| SoapAction | permanent |  |  |  |  |
| Status-URI | permanent |  | 2518 | RFC 2518 |  |
| Strict-Transport-Security | permanent |  | 6797 | RFC 6797 |  |
| Sunset | permanent |  | 8594 | RFC 8594 |  |
| Surrogate-Capability | provisional |  |  |  |  |
| Surrogate-Control | provisional |  |  |  |  |
| TCN | permanent |  | 2295 | RFC 2295 |  |
| TE | permanent |  | 9110 | RFC 9110, Section 10.1.4 |  |
| TTL | permanent |  | 8030 | RFC 8030, Section 5.2 |  |
| Timeout | permanent |  | 4918 | RFC 4918 |  |
| Timing-Allow-Origin | provisional |  |  |  |  |
| Topic | permanent |  | 8030 | RFC 8030, Section 5.4 |  |
| Traceparent | permanent |  |  |  |  |
| Tracestate | permanent |  |  |  |  |
| Trailer | permanent |  | 9110 | RFC 9110, Section 6.6.2 |  |
| Transfer-Encoding | permanent |  | 9112 | RFC 9112, Section 6.1 |  |
| URI | obsoleted |  | 2068 | RFC 2068 |  |
| Unencoded-Digest | permanent | Dictionary |  |  |  |
| Upgrade | permanent |  | 9110 | RFC 9110, Section 7.8 |  |
| Urgency | permanent |  | 8030 | RFC 8030, Section 5.3 |  |
| Use-As-Dictionary | permanent | Dictionary | 9842 | RFC 9842, Section 2.1 |  |
| User-Agent | permanent |  | 9110 | RFC 9110, Section 10.1.5 |  |
| Variant-Vary | permanent |  | 2295 | RFC 2295 |  |
| Vary | permanent |  | 9110 | RFC 9110, Section 12.5.5 |  |
| Via | permanent |  | 9110 | RFC 9110, Section 7.6.3 |  |
| WWW-Authenticate | permanent |  | 9110 | RFC 9110, Section 11.6.1 |  |
| Want-Content-Digest | permanent | Dictionary | 9530 | RFC 9530, Section 4 |  |
| Want-Digest | obsoleted |  | 3230 | RFC 3230 | Obsoleted by [RFC 9530, Section 1.3: Digest Fields] |
| Want-Repr-Digest | permanent | Dictionary | 9530 | RFC 9530, Section 4 |  |
| Want-Unencoded-Digest | permanent | Dictionary |  |  |  |
| Warning | obsoleted |  | 9111 | RFC 9111, Section 5.5 |  |
| X-Content-Type-Options | permanent |  |  |  |  |
| X-Frame-Options | permanent |  |  | HTML |  |

Source: https://aidb.si/d/http-header-fields — Source: Internet Assigned Numbers Authority (IANA), HTTP Field Name Registry.

